Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I often start Calculator by pressing the little Calculator button on my MS keyboard - but for some stupid reason it always starts minimized - meaning I have to restore it first before I can use it. Any idea why it would do this?

It appears to start fine if I start it any other way.

Update: I've just realized this only happens when Visual Studio 2008 is in focus - which is a lot of the time on my machine. Weird! Still annoying though.

Update 2: OK, so it's not just Visual Studio - but Calculator starts without focus in all programs. Some programs it starts under, and some programs it starts over the top, but still not focused - so you have to click on the program itself or on the taskbar.

share|improve this question
what version of windows are you using? – lexu Aug 20 '09 at 4:43
Man... I so want to say "Because you touch yourself at night." or something... really, that's an odd problem to have. I suggest remapping the calculator button and see if that fixes the problem. – mpen Aug 20 '09 at 4:47
Using Vista x64 Business Edition. I know it's odd - I even tried remapping it to start calc.exe manually, but it just does the same thing :| – wows Aug 20 '09 at 4:50
Interesting. Any other programs launch minimized when VS is in focus? IE, Outlook Express? – hyperslug Aug 20 '09 at 5:05

I had the same problem with Windows 7 x64. I fixed it by creating a command file calc.cmd with the following lines:

start C:\Windows\System32\calc.exe 

Then I assigned the key to run the command file, and calc now starts in the foreground.

share|improve this answer
Also a work-around. Let’s try to fix the problem. – Synetech Apr 5 '10 at 16:04
Works for me, Windows 10, Logitech K270 – Seraphim Apr 2 at 15:12

One was this could happen is if that key is mapped to a shortcut with Run set to Minimized. What kind of MS keyboard?

share|improve this answer
It's a standard MS Digital Media keyboard - nothing special. I've looked in the Microsoft Keyboard settings and all the calculator key does is start Calculator. No other options there (such as start minimised, etc). – wows Aug 20 '09 at 4:47
I can confirm I have the same keyboard and have never experienced this problem. – BinaryMisfit Aug 20 '09 at 7:01
But how does it start the calculator? Does it run calc.exe or does it just “run calculator”. What exactly is displayed in the configuration dialog? – Synetech Apr 5 '10 at 16:05

You can use an AutoHotkey fix:

WinWait, Calculator

or compile the following script, drop it into system32 and rename calc.exe to calcX.exe and name this compiled script calc.exe.

Run, calcX.exe
WinWait, Calculator
share|improve this answer
not sure which key AHK uses for calculator in specific, or i'd have a solution to map that key to the above. I know the scan code for the calculator button is E0_21, but I don't know what the AHK authors named it. – John T Sep 21 '09 at 2:44
That is just a work-around and doesn’t really address the problem. The OP already has a work-around (restoring the calculator after running it), so it would be better to figure out what the problem is and fix it. – Synetech Apr 5 '10 at 16:04
-1 Replacing system files is dangerous. – kinokijuf Aug 26 '12 at 15:36

It looks like there is not going to be a straightforward answer for this. It is going to require investigation and debugging of your system. Fortunately most of us here love doing exactly that, so let’s start. :)

Try mapping it to something else, say Notepad for example. What happens? Try mapping a different extended button to the Calculator. What happens then? The goal of this step is to see if it is the calculator that is the problem or the specific button.

share|improve this answer
That's not only the case of calculator, actually every single program that I start using keyboard shortcuts, like web browser, communicator, music player, and even folders like my documents, my music, my pictures - they're all always start unfocused. A picture of buttons that I'm writing about: , key assignment: – Lord_Blizzard Mar 1 '12 at 8:21
  1. Windows start menu;
  2. All Programs;
  3. Accessories;
  4. Calculator;
  5. Right-Click Calculator and select Properties.
  6. Under the Shortcut tab half way down is the Run attribute; change its property to “Maximized”.

Run your normal shortcut key to open the calculator in maximized state.

share|improve this answer
he doesnt want to start it maximized. – Keltari Sep 3 '11 at 18:10
@Keltari: Did you actually read his answer before commenting? – Tom Wijsman Dec 5 '11 at 14:09

Whilst my keyboard is not a MS keyboard but a Logitech keyboard, I had the same problem. It would either start minimised or out of focus. It was very annoying especially as I use it a lot.

To fix this problem I changed the keyboard button allocation from 'Default Task' (IE: Calculator) to 'Launch Program', then browse to the calculator application (often located in 'C:\Windows\System32\calc.exe') then clicked Apply.

Worked for me...

share|improve this answer

Had the same problem, fixed this way:

  1. open the ms mouse and keyboard settingsin control panel
  2. select the calc key
  3. disable
  4. enable (calc)


share|improve this answer

protected by Community Aug 19 '15 at 8:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.