Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two servers (lets say A and B). In order to ssh into A, I need to ssh into B first, and then into A. I want to run some GUI applications on A, so I am looking to forward X11 twice over ssh.

However when I run an application from A I get:

Error: no display specified
share|improve this question

migrated from stackoverflow.com Mar 25 '11 at 7:53

This question came from our site for professional and enthusiast programmers.

Make sure that you're adding the -Y flag, and that X11 forwarding is enabled in both servers' ssh config files in /etc/ssh/sshd_config.

share|improve this answer
    
yes and yes ... – Vaibhav Bajpai Mar 22 '11 at 17:13

would the following work for you?

export DISPLAY=serverB:0
share|improve this answer
    
well, I gave export DISPLAY:IPAddressOfB:0 (didn't work) – Vaibhav Bajpai Mar 22 '11 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .