Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop (1.5 yrs old, Intel Core 2, 3G memory, NVidia graphic card, Windows XP Pro) that I use Visual Studio Professional. VS2010 is installed in C: drive where it has 92GB and has a free space of 50GB.

VS2010 has been slow 1. When switching from other tasks, the UI simply freezes for > 1 minute before it responses to the mouse click; 2. Sometimes it takes a couple of seconds even when I switch to another tab/file before the UI responds; 3. Takes >2 min to build even a small solution (with a dozen projects) that usually takes <1 in Blend. The task manager shows VS usually takes 200MB - 330MB of memory, which is on top of the list, with browser (Chrome or Firefox) in the 2nd place taking around 150MB.

I've tried to reset VS2010 settings and it doesn't seem to take any effect. Any leads are appreciated!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Make sure you got the latest service pack.
Disabling intellisense helped my VM instance running VS, you may also want to try disabling any 3rd party components.
You could also try forcing garbage collection (shift + ctrl + alt + f12)x2

share|improve this answer
    
Thanks for the suggestions. It does seem to have to do with the designer view. UI hangs when I tab through different .xaml files that are in designer but .cs files load much faster. changed the .xaml default to associate with "Source Code Text editor" fixed the freezing issue; but VS still slow when launching and working with TFS... –  mobileTofu Mar 28 '11 at 16:44
    
Now my solution is to have Expression Blend and Visual Studio open side by side. I use VS editor and Blend to build. Seems to be working for me! –  mobileTofu Mar 29 '11 at 19:16
    
Nice! Glad it's working better. For me it's just been that VS2010 GUI is in WPF now (which has been my biggest slow-down) –  Justin Mar 30 '11 at 19:18
    
Another follow up: Symptom: VS2010 took long to load/build/debug projects. Figured out those projects were in TFS. Solution: Disable "source indexing"(?): In VS2010 > Tools > Options > Debugging > Symbols > Automatically load symbols for - Only specified modules. social.msdn.microsoft.com/Forums/en/tfsgeneral/thread/… –  mobileTofu Apr 1 '11 at 16:27
    
Hi Justin, Did you try to disable hardware acceleration and force VS to use software acceleration? –  mobileTofu Apr 1 '11 at 16:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.