Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run both Ubuntu and Windows 7 machines. I would like to use an external HDD. I read that if it is formatted to FAT32 bot OS's should read it. Win7 is not reading it. How do I get Windows to read/open a FAT32 formatted HDD?

When I go to Devices and Printers I can see the disk.

share|improve this question

If you have formatted the entire drive as FAT32, without splitting it into partitions, Windows might get confused (I think). If that's the case, you'll need to backup all your data, partition the external drive (which will destroy all your data), using e.g. fdisk (text-based) or gparted (GUI), and create a new FAT32 partition. You don't have to create any other partitions.

share|improve this answer

it could be a drive letter issue. go to Disk Management and try assigning it another drive letter.

share|improve this answer
    
Thank you for your answer. The option Change Drive Letter and Paths... is grayed out. – Keith Groben Mar 25 '11 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .