Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So my computer, ASUS MB, ThermalTake PSU, won't turn on after shutting down last night.

Short of taking out the powersupply and putting in a new one, are there any tricks to figuring out/fixing the problem?

Edit -

The powersupply has an amber LED which lights up when it has power, and turns green when the computer is on. In the current state, the LED stays at amber, and nothing happens when I press the computer power button. No fans, no HD

share|improve this question
    
Any beeps at startup? Any indicators on the motherboard maybe? –  M'vy Mar 25 '11 at 20:40
    
You need to be more specific as to what you mean by not turn on... if it doesn't start at all no fans or anything then sounds like your power supply is dead, wire is lose, switch on back set wrong, wall switch turned off that it is connected to....... can go on and on. –  Arctor Mar 25 '11 at 20:45

3 Answers 3

up vote 2 down vote accepted

Strip all unnecessary hardware out of the computer - soundcards, network cards, hard drives - everything. Leave just the motherboard, processor, memory and video card. If it still doesn't power up remove the video card and listen for the "No video card" POST beeps. If it still doesn't work try removing the memory and listening for the "No memory" POST beeps.

If stripping it down to the bare bones makes it work then start addnig the extra hardware back one item at a time until it fails - that last pece of hardware is the culpret.

If nothing makes it show any life then it's either the motherboard, CPU or power supply. Try replacing them one at a time until you get something.

If you're feeling adventurous you can test the PSU by unplugging it from everything (even the motherboard) and connecting it to one spare device (an old hard drive would be ideal) to give it some load. You can then insert a paperclip into the large motherboard connector linking a green wire (pin 14) to a black wire (pin 15) - this should force the power supply to turn on and power up the device you have connected.

share|improve this answer

Turning the PC over on it's side helped. Two MB LEDs were lit, pressing one powered it up. Seems that the connectors from the switch to the MB were loose.

share|improve this answer

If there's no change at all when you push the power button and it's not something silly like the cord is unplugged or the plastic switch has broken, it's almost always that you need to replace the power supply itself. No guarantees, but I'd say this with about 85% certainty.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.