Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using git on my Ubuntu machine with my existing ssh keys.

Now I have to use Git on Windows 7, and need to use the same keypairs.
I have set up msysgit and created an .ssh folder in Users\username\.ssh.
I have copied my keypair from Ubuntu's .ssh folder to this folder.

But when I try to clone the Git repo, it stops and asks for the password.
According to some tutorials, I should have some options during the msysgit installation regarding ssh, but I saw none.
Do you have any suggestions to solve this?

share|improve this question

1 Answer 1

up vote 10 down vote accepted

You need to set your HOME environment variable to whatever directory you selected for creating the .ssh folder (it doesn't have to be necessarily Users\username\).

%HOME% isn't a native environment variable (%HOMEPATH% is), and the mingw Unix-like session of msysgit is entirely based on the $HOME value.

share|improve this answer
    
Thanks, but how do I add this HOME env. variable? –  Burre Mar 28 '11 at 0:20
    
@Burre: simply define a User environment variable called HOME in your Windows settings, like described in itechtalk.com/thread3595.html. –  VonC Mar 28 '11 at 5:37
    
Thank you very much! –  Burre Mar 28 '11 at 12:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.