Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Internet Explorer and Firefox on Windows 7. I dual boot with Ubuntu, which has a fully-working copy of Firefox 3.86.

On the Windows partition, Internet Explorer works fine, but Firefox 4 will not load any pages. I have run Super Anti Spyware and Spybot S&D which found a few issues - but nothing major - so I think it may be an OS issue with the registry, or a problem with Firefox itself.

I am unsure why Firefox redirects to a "not connected" screen every time I try and load a page. I've also uninstalled and reinstalled Firefox 4, and am contemplating going back to 3.6.

Any thoughts on why Firefox 4 is not working properly for me?

share|improve this question
    
have you set the proxy configuration (if you are using a proxy server to connect to the net)? –  Shekhar Mar 26 '11 at 6:08

4 Answers 4

Having had the same problems after upgrading to Firefox 4, the solution that worked for me was to allow Firefox through the firewall. It worked in both Windows XP and Windows 7.


Windows XP

  1. Navigate to: Control Panel > Windows Firewall > Exceptions.

  2. Highlight Mozilla Firefox (which may already be shown as 'allow' but this can often be incorrect in reality) and choose Delete. You will be asked to confirm, click Yes.

  3. Restart the computer.

  4. Navigate to: Control Panel > Windows Firewall > Exceptions.

  5. Click Add Program, find Firefox in the list and add it.


Windows 7

  1. Navigate to: Control Panel > System and Security > Windows Firewall > Advanced Settings > Inbound Rules.

  2. Right click to use the wizard; if you choose not to use the wizard you probably just needed to get to this point and can do the rest of the steps on your own.

  3. Click New > Next > Browse and from the left pane choose C: - from the right pane choose Program Files (x86) then Mozilla Firefox. If you can't find the Firefox folder than it may be installed under Program Files on your system.

  4. Click Next then Allow the Connection. Choose the level of allowances that are appropriate to your situation (all for me).

  5. Click Next then give it a name, e.g. Firefox browser.

  6. Restart the computer

share|improve this answer

Try following Mozilla's Basic Troubleshooting steps for Firefox. I would recommend at least trying to reset Firefox's settings back to default:

Reset your Firefox settings

Some problems can be fixed by resetting your Firefox preference settings:

1) At the top of the Firefox window, click on the File menu and select Exit. Then in Windows, click Start, open the All Programs list and navigate to the Mozilla Firefox folder. In the Mozilla Firefox folder, select Mozilla Firefox (Safe Mode). Firefox will start up with the Firefox Safe Mode dialog.

Note: You can also start Firefox in Safe Mode by clicking Start, selecting Run (or use the Start Search box in Windows 7 and Vista) and then entering the following in the text field: firefox -safe-mode`

2) In the Firefox Safe Mode dialog, click to put a check mark by Reset all user preferences to Firefox defaults.

3) To apply your changes, click Make Changes and Restart.

share|improve this answer

When I upgraded to Firefox 4 it also switched to off-line mode. Make sure it's not something as simple as that.

The corresponding menu item seems to be gone with the new "Start" button but you can turn it off from the "File" menu if you make the menu bar back. In order to do that you need to find a blank place in the toolbar (for instance, click between the "Back/Forward" button and the location bar), right click on it and select "Menu bar".

share|improve this answer

"Error loading websites" http://kb.mozillazine.org/Error_loading_any_website

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.