Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got last summer a Toshiba Qosmio laptop with Windows 7 64 bits preinstalled. It just works very poor. It feels... choppy. Compiling a large program 4-5 seconds. All programs are less responsive.

On Windows 32 it takes 1.5 seconds. It seems to be because it takes quite a while until the CPU frequency switches from low power state to 100%. Is this a know problem with all 64bit OS?

Initially I worked with the software/drivers preinstalled by Toshiba (an believe there were few GB of garbage preinstalled). Then I reinstalled and I put only the (minimum set of) drivers and no garbage utility software. The laptop is as choppy as before.

share|improve this question
    
You should be able to disable CPU power saving in the BIOS. –  Joe Internet Mar 26 '11 at 12:52
    
You mean on Win 64 bit only. Right? Because on Win32 it works properly. –  Altar Mar 28 '11 at 12:37
    
Sure, on either. The laptop's BIOS might be configured to put the CPU in power save mode. You should be able to disable this. –  Joe Internet Mar 29 '11 at 14:39
    
First, how many RAM do you have? Win 7 x64 seems to consume much more of it than x86. So x86 will work better for computers with lower hardware. "Compiling a large program 4-5 seconds." this is a very small program in my opinion. –  Michael K May 18 '11 at 10:25
add comment

2 Answers

Well that's what you would get for power saving, the OS determines the use of CPU power based on CPU Usage. Compiling most likely will not bump your CPU to 100% therefore it will not reach it's maximum clock that it's set to. If you want to use the CPU to the best of it's ability set your Power Options profile to "High Performance" and you will get a constant high speed CPU.

share|improve this answer
    
But Win 32bit does not behave like that. –  Altar Mar 28 '11 at 12:36
    
I have been using 64 bit since it first released on Vista and still using it on Windows 7 now. It has been working fine. try looking through drivers that may be causing the system to behave in a weird way. –  Sandeep Bansal Mar 28 '11 at 20:40
add comment
up vote -2 down vote accepted

I switched to Win 7 32 bits and everything works smooth now. I guess we will have to wait until MS optimizes this (relatively) new 64 bit OS.

share|improve this answer
    
"I guess we will have to wait until MS optimizes this (relatively) new 64 bit OS." Actually x64 is not a new technology and win 7 (and also vista) x64 is on the same development level as the x86 version. –  Michael K May 18 '11 at 10:26
    
I run 64 bit on three platforms with no issues, as others have pointed out look at your bio's and power settings. –  N4TKD May 18 '11 at 10:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.