Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Mac OS X system is mostly getting the wrong ip address from any router. It gets an IP address starting with, when it should be getting a good, old or something.

Does anyone know what could be the cause? I've got the feeling it happens after the laptop goes into stand-by mode.

I also see this message: "Airport has a self assigned IP address and may not be able to connect to the internet."

I've read people think it's because the router isn't handing out ip addresses, but it works just fine on any Linux or Windows laptop.

share|improve this question

migrated from Mar 26 '11 at 11:51

This question came from our site for system and network administrators.

Sounds like your dhcp client (if you say the error occurs with ANY router) has problems when getting out of the stand-by. ( If you renew your dhcp address when you get back from stand-by everything works? – Pitto Mar 26 '11 at 12:29
That theory does sound familiar, strange enough I have to renew 10-15 times before I get a correct IP. – skerit Mar 29 '11 at 13:55
up vote 4 down vote accepted

The IP address is not being provided by your router but is being created by your computer in an attempt to communicate with your router's DHCP server - and failing. You should check the wireless connection to make sure it's actually attaching to the network and the authentication details are correct.

share|improve this answer
Indeed, but the mac says the connection is OK. I even disable airport, re-enable it and it still doesn't get an ip address from the router. Lots of people think it has to do with the mac coming out of standby. – skerit Mar 29 '11 at 13:57

The routers are not the problem. The problem is your Mac. Run a software update. Since you say this issue occurs only sometimes, this leads me to believe its not your network settings (which should take effect all the time).

Most likely you need a driver update. If all your drivers are up to date and the problem continues I suggest you try a reformat. If it still doesn't work replace the wireless network card.

share|improve this answer

Please check the list of preferred networks and delete network names you do not use. To do this, open System Preferences... >>Network Select your Airport name, click Advanced... at bottom right, use the '-' to delete unneeded preferred networks.

share|improve this answer

In Network in System Preferences go to Airport then Advanced. You should see a weird-window popup, select TCP/IP. It should say Configure IPV4, pick Using DHCP so that your computer asks the router for all it needs.

I had this problem recently, I had set my own internal ip address, then when I used another wireless point it didn't work, it took me ages to realise I had also set the router/gateway address to what I used at home.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.