Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two laptops, running Vista and XP. The Vista laptop is able to connect to a public wireless network. The XP can't connect to the wireless network, so I would like to share it somehow. I have a switch and network cables. But when I try to configure the Vista laptop to share the network, it looses connection to it. It seems that I must use a static IP, which I don't seem to be able to do for this network.

Any suggestions or workarounds?

share|improve this question

5 Answers 5

When using ICS, you need to share the outbound connection, not the local one. Share the wireless connection, and Windows should set your Local Area Connection to a static address.

It will begin performing DHCP over that interface. Plug in an Ethernet cable to another PC, and it should acquire an IP address from your PC, and be able to browse the internet.

I don't have a Windows Vista machine in front of me, but the process should be something similar to this.

share|improve this answer

As you learned through experimentation, sharing a single connection requires a static IP on the outbound address.

You could get a DHCP address, then reconfigure your machine to match it statically. Of course, you'll need to repeat this process whenever you reconnect if the DHCP lease has expired.

A better question is why your XP cannot connect. Just guessing, but fixing that would likely bring you better response from both machines.

share|improve this answer

configuring a static IP on the wired link may not be necessary as windows will fall back to a 169.x.x.x address if no DHCP is found. Since all machines pick a 'random' number from that network they will be in the same subnet but not have the same address, meaning it should work just fine. I have done it plenty of times. Just to be sure you are not plugging straight from the laptop to the desktop are you? A special (crossover) cable is required for that. If you plug them both into the switch it should work fine.

All of the static IP configuration should not be necessary.

If i have to guess I would say the problem may be more related to using both network adapters at the same time (wired & wireless)

share|improve this answer

When you use wireless, it would most likely be the 192.x.x.x range, if you then enable internet sharing, I believe that it tries to set your local pc to 192.168.0.1 and act as the network router which would mean that you get routing problems.

If I was you, write down the ip that you get from the wireless network, if it starts with 10, go to step a, if it starts with 192, go to step b.

Enable internet sharing through the normal method.

Go to control panel > Network and Internet > Network Connections (I am using Win 7, but I think it is the same).

Right click on the wired network card and click properties, then double click TCP/IP Settings

Step A

Set your machines IP to 192.168.0.1,

Step B

Set your machines IP to 10.0.0.1

--- Both

Set Subnet Mask to 255.255.255.0 Set Gateway to the router's IP address Set DNS either to openDNS or the IP of the router (depends on features you use)

Now, on your other pcs, you may get incorrect DHCP leases. Set it to manual as above but use.

STEP A

IP 192.168.0.x (must be unique)

Gateway 192.168.0.1

DNS either opendns or 192.168.0.1

STEP B

IP 10.0.0.x (must be unique)

Gateway 10.0.0.1

DNS either opendns or 10.0.0.1

--- Both Subnet 255.255.255.0

share|improve this answer

The wireless network shouldn't require a static ip. Your wired connection however need a static ip configured because it will act as a router for your xp machine.

set your ip on your wired connection to something like 192.168.0.1 and try configuring the sharing again and it should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.