Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been unable to write to my NAS recently. When I go to save a file to one of the folders I get the message "you dont have permission to save to this location" . I can see all the folders and files on the NAS ok. When I go to check the permissions on a folder -- Properties - Security, I see that the groups listed are Everyone, guest and anyone. But only the "Special Permissions" box is checked.

Easy to fix you might think. Edit permissions and click on Full Control. Click on OK. BUT I get a message box. Error Applying Security. An error occurred while applying security information to \NAS\public Access is denied.

This has been driving me nuts because previously I had been using the NAS to back up everything using Acronis, but now Acronis doesn't back up and I can't even save a small text file.

I have tried disabling Homegroup I have tried Taking Full Control for the application being used. and lots of other stuff. All without successs.

Setup: Windows 7 Ultimate 64 bit PC NAS is a Agestar 1TB running Fat32. Also another Win 7 PC on the home network.

I am a very experienced user but this has beat me.

Thanks for all replies.

Muzz

share|improve this question

1 Answer 1

Connect to your NAS administration application and see if something has changed on the NAS that forced it into read-only mode. Perhaps there is a setting that makes the drive read-only, or there may be a user-id setting on the NAS for the shared folders that is preventing access.

share|improve this answer
    
Thanks for the reply. Yes I have checked all that as NAS administrator. All users have Full Access. –  muzz Mar 28 '11 at 2:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.