Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Why can't I traceroute or access certain websites in my browser even though I can ping them from terminal?

I'm running a MacBook Pro connected via WiFi to my home router. When I try to access some websites, I get the could not connect error message. Originally I thought the site was down but when I access it on my phone, connected to the same WiFi network, the websites come up fine.

I've tried Firefox, Chrome and Safari and none will load the page. The phone is an Android device. Both the default browser and the Miren browser work ok.

What can cause this?

-- Update --

Not sure if this helps but if I do an nslookup www.website.com it gives me a list of IP addresses. These match the addresses that come up if I Google the IP address of the site. If I just use the IP address in the browser eg http:// It still fails to come up.

share|improve this question

marked as duplicate by random May 6 '11 at 1:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Most of my ideas you couldn't do by mistake, meaning it would only be as a result of a setting you put on. But I figured I'd list them anyway. Ordered in a somewhat most likely to least likely way.

  • You have manually set DNS entries in one of the devices but not the others, e.g. OpenDNS. The DNS server in the unworking device is filtering said website.
  • You've set a proxy for one device but not the other. The proxy is malfunctioning.
  • You're iPhone is accessing the site through 3G. Routing issue between your ISP and the site, but not between AT&T (or whoever) and the site.
  • One device is auto-detecting the proxy but not the other. The proxy is malfunctioning.
  • Malfunctioning round-robin DNS load balancer on the site. DNS is now cached in both of your devices, but only one of the sites is up.
  • Browser cached page in one device but not the other.
  • Manual hosts entry in MacBook points to wrong site.
  • Firewall rule preventing connections to/from MacBook's ip address but not iPhone's address.
  • The site blocks OS X user agent string, but not MobileSafari.

EDIT: Odd. Well, first thing I'd try is a traceroute. From terminal on the Mac, type "traceroute web.site.com" where web.site.com is the site you're trying to access. There's iOS apps that do tracerouting which I would do as well. Make sure the IP address is the same and also check if the routes are wildly different.

share|improve this answer
    
Thanks. Been going through these but nothing has got it going yet. I've updated the question a little to cover some of them. –  sickgemini Mar 28 '11 at 22:28
    
Added something to test –  emgee Mar 28 '11 at 23:04
    
Found this superuser.com/questions/261706/… Checked my login items and there were a couple related to peer guardian. Removed them and all is good now. Thanks heaps for you help. –  sickgemini Mar 29 '11 at 11:01

I don't know about Mac, and I don't know why this happens, but on Windows, I flush the DNS cache with:

IPConfig /FlushDNS

and it works fine.

Apparently you can say

dscacheutil -flushcache

in Mac, and it'll do the same thing, though I haven't tested this.

share|improve this answer
    
Thanks. Tried the MAC version but no luck. –  sickgemini Mar 28 '11 at 19:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.