Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to edit a file in a remote directory (through SSH, SFTP or FTP) I must close the file to get a dialog box tell me if I want to upload the file. I want to upload it automatically on save!

I've already used Konqueror/Dolphin/Krusader as file managers and many other text editors but without any success. It seems that the problem is in the KIOExec application.

How can I edit KIOExec to automatic upload files on save? I don't want to return to using Gnome!

share|improve this question
add comment

3 Answers

But transfer-on-save is already the normal case. You cannot "edit KIOExec". Upgrade KDE to the latest stable version.

Double-clicking makes a local copy, this is for the benefit of non kio-enabled applications. If you really need to involve a file manager (instead of simply navigating from the editor itself), just drag & drop the remote file into the editor.

share|improve this answer
    
stop to tell that I should upgrade to the last version: every time boefore ask people usually update to the last version. –  Emergento Apr 1 '11 at 11:58
    
My good man, you cannot be helped if you do not let people help you. Good day, and I will not be bothering you again. –  daxim Apr 1 '11 at 12:01
    
Transfer-on-save is not the normal case if you initiate the editing from Dolphin (double click on the file to be edited to launch Kate, for example). –  Palantir Nov 12 '12 at 12:46
    
Double-clicking makes a local copy, this is for the benefit of non kio-enabled applications. If you really need to involve a file manager (instead of simply navigating from the editor itself), just drag & drop the remote file into the editor. –  daxim Nov 12 '12 at 13:23
add comment

Although this is a somewhat old question it still is unanswered. I also wanted to:

  • open Dolphin/Konqueror with sftp://user@remotesite/
  • choose to open a file to edit
  • have upload on save working

As described by the original poster, the upload only happens after closing the editor.

The only way to have something similar to this working is using kate and opening the file from kate. Stating the sftp://user@remotesite/filetoedit on open.

Here the upload on save works.

After the open with menu on dolphin updated to have kate, the open with kate also had the upload on save. Before, when manually stating kate in open with other it did not work.

P.S. I'm using kubuntu 11.10 with packages updated today.

share|improve this answer
    
Great, at least Open with Kate seems to work for 12.04, too. Thank you for sharing your experience. –  SebastianG Nov 3 '12 at 18:55
add comment

Your best bet is to probably use sshfs. This lets you mount the remote resource to a directory of your choosing, after which it behaves like a local filesystem (albeit with some lag).

sudo apt-get install sshfs

Create a remote mount point, say /mnt/remote (could always use ~/MyCode/RemoteServerA too)

sudo mkdir /mnt/remote;
sudo chmod 777 /mnt/remote

Then mount the filesystem:

sshfs user@remotesite:/path/to/directory

Now you can browse the filesystem with Dolphin and edit files normally, and they'll upload when you save. No need for any configuration beyond ssh on the remote host!

When you're done, remove the filesystem with

sudo umount /mnt/remote

If you get an error that it's in use, use

lsof /mnt/remote

to get a list of processes still using the mounted directory. You may need to configure file-indexing (if you use it) to avoid this mount point.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.