Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My son needs to be logged into his own account but we restrict his usage by logging him in with a PW he doesn't know. He figured out he can change his password negating our control.

Is it possible to lock his ability to change his own password?

share|improve this question
add comment

4 Answers 4

If you are running a Home edition of Windows 7 and therefore cannot access the Local Users and Groups management console, you can achieve the same effect using the command line tool net user.

Open a elevated command prompt (right-click on the command prompt under the start menu and choose Run as Administrator), then run

net user UserAccountName /passwordchg:no

This will prevent the user from changing their password.

share|improve this answer
add comment

Open the start menu and right-click on "Computer", and select "Manage". If your account isn't an administrator, you may have to provide administrator credentials.

Right-click menu

In the Computer Management window, expand "Local Users and Groups" on the left, and click on "Users".

On your son's user account, right-click and select "Properties".

In the properties window, select "User cannot change password" and "Password never expires".

Click for a big version!

Click okay and close the windows, you're done! Your son won't be able to change his password until that setting is changed.

share|improve this answer
add comment

This works in XP Pro, not sure that it works in all versions of Windows 7, but if you right click on My Computer, choose Manage, go to Local Users -> Users, right click on his account and hit properties, there's a check box for "User cannot change password"

It's worth a try. Obviously his account should not be a Administrator one if you don't want him changing this back.

share|improve this answer
add comment

Run lusrmgr.msc This will pull up local users and groups. Browse to users. Select userid, right click select properties, check "user cannot change password" OK.

share|improve this answer
    
Does not work on Windows 7 Home versions, FYI. –  studiohack Mar 27 '11 at 7:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.