Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've noticed that after I reinstalled Yahoo! Messenger 2 weeks ago, clicking on a link in a chat window opens in IE, while before it was defaulting to Firefox. How can I change the default browser back to Firefox?

My default browser is Firefox.

I forgot to mention my OS is Win XP SP3 and I'm using Yahoo! Messenger version 8.1.0.421

share|improve this question

2 Answers 2

up vote 4 down vote accepted

You can have Firefox check right now if it is the default browser:

Tools > Options > Advanced > System Defaults

Then click Check Now.

You will see a prompt which will tell you if it is or isn't. If it isn't, simply click Yes and it will set itself as the go to browser for your computer.

On top of that, you may also need to check the following box:

☑ Always check to see if Firefox is the default browser on startup

When you re-installed YIM, it might have reset your default browser to Internet Explorer.

If that still doesn't work, Firefox might be only thinking that it's set as the default. In which case, go to the Control panel for Programs:

Start > Control Panel > Add or Remove Programs > Set Program Access and Defaults

Then open up the Custom configuration and set Mozilla Firefox as your default browser.

add or remove programs dialog

Click OK and YIM should now open up any links in the default browser, which has been set in this case as Firefox.

share|improve this answer
    
I've tried your suggestion, but Firefox was already set as my default browser. Yahoo! Messenger is still using IE as default browser. –  alexs Aug 20 '09 at 9:18
    
YIM might have reset it to IE as well as FF no longer knowing if it is the default. –  random Aug 20 '09 at 10:00
    
I reset Firefox as my default browser in "Add or Remove Programs" - "Set Program Access and Defaults" panel closed YIM and after I opened YIM it is using Firefox as default browser. THX. –  alexs Aug 20 '09 at 11:33

In Firefox 3:

Tools -> Options -> Advanced -> General. Toward the bottom of the window there's a section called System Defaults. Click "Check Now".


Looking around, it seems that Yahoo Messenger can ignore the default. So if that doesn't work and try this:

Start -> Control Panel -> Add or Remove Programs -> Set Program Access and Defaults -> Custom -> Choose a default Web browser: Select Firefox -> OK

For those w/ Vista try this:

  • Click the Start menu
  • Click Default Programs
  • Click “Set program access and computer defaults”
  • Select Custom then click on the drop arrow
  • Look for “Choose a default web browser” and select Mozilla Firefox
  • Click OK
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.