Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am are using a windows program under linux via wine. The program runs fine with KDE. Didn't test it on gnome. Finally we wanted to start the program without KDE - something like kiosk mode, so users not to be able to use anything but this gui program. I do that by:

startx the_program.exe

The program runs and it works, but the fonts are not antialised at all. xfs server is started:

[root@mclive5 ~]# chkconfig --list|grep -i xfs
xfs             0:off   1:off   2:on    3:on    4:on    5:on    6:off

"startx firefox" works just fine and with anti-aliasing.

Linux distribution is CentOS 5.5, wine is 1.2.1 (1.2.1-1.el5.rf from romforge)

Any ideas how to turn on antialising?

share|improve this question
    
I think the answer is under 5.5.3: freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-fonts.html I'm mobile or I'd spell it out more. –  0x90 Mar 25 '11 at 12:08
    
I've read that. I tried to use <edit name="antialias" mode="assign"> <bool>false</bool></edit> in /etc/fonts/fonts.conf. I also have file /etc/fonts/conf.d/10-antialias.conf with this contents:<?xml version="1.0"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <fontconfig> <match target="font"> <edit mode="assign" name="antialias"><bool>true</bool></edit> </match> <match target="font"> <edit mode="assign" name="autohint"> <bool>true</bool> </edit> </match> </fontconfig> it didn't help –  NickSoft Mar 25 '11 at 12:27
    
The link you gave me shows how to turn off anti-aliasing for mono fonts in KDE, not how to turn it on when not using KDE –  NickSoft Mar 25 '11 at 12:34
add comment

migrated from stackoverflow.com Mar 27 '11 at 7:38

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 0 down vote accepted

Solved it! I wrote this in a file named "wine.reg":

REGEDIT4

[HKEY_CURRENT_USER\Control Panel\Desktop]
"FontSmoothing"="2"
"FontSmoothingOrientation"=dword:00000001
"FontSmoothingType"=dword:00000001
"FontSmoothingGamma"=dword:00000578

then I run:

wine regedit wine.reg

Works like charm

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.