Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem: Some big websites like homedepot.com and cbc.ca websites will not resolve. The browser just sits there and no content is shown. What could be causing this? Also get

Request timed out.

with ping.

nslookup

C:\Documents and
Settings\rwhite>nslookup homedepot.com
Server:
google-public-dns-a.google.com
Address:  8.8.8.8

DNS request timed out.
    timeout was 2 seconds. Non-authoritative answer: Name:
homedepot.com Address:  207.11.41.2

Also, the windows hosts file only has a single line:

127.0.0.1       localhost
share|improve this question

migrated from serverfault.com Mar 27 '11 at 21:09

This question came from our site for system and network administrators.

    
Which OS do you use if you use windows go to the command line and type "nslookup". Then you can type in your site and check if the DNS resolve the name. –  Stony Mar 27 '11 at 21:10
    
Sounds like an issue with your ISP. –  ChrisF Mar 27 '11 at 21:11
    
I guess one idea would be to try to narrow it down to whether the problem's your computer, or some glitch at your ISP (or with the modem/router). Do you have a laptop? Plug it into the same internet connection and see if it also fails to connect to these sites. If so it's not your computer settings, look at your modem/router settings. If nothing stands out, call your ISP. –  CreeDorofl Mar 27 '11 at 21:13
    
@Stony - WinXP Pro –  O.O Mar 27 '11 at 21:15
    
@CreeDoroftl the only access I have at the moment is with remote desktop. Already called ISP and they claim everything is fine. DSL modem has all security restrictions disabled. I've tried to use google's DNS servers but nothing changes. –  O.O Mar 27 '11 at 21:17

2 Answers 2

If I type:

ping homedepot.com

I get:

Pinging homedepot.com [207.11.41.130] with 32 bytes of data:

Request timed out.

But if I type:

ping www.homedepot.com

I get:

Pinging a472.b.akamai.net [84.53.134.200] with 32 bytes of data:

Reply from 84.53.134.200: bytes=32 time=42ms TTL=58

Notice the difference. The subdomain www.homedepot.com resolves straight away, but not homedepot.com. However, if I type homedepot.com into a browser it takes me to the site at www.homedepot.com.

The site could well be configured to reject ping and other requests as a security measure.

cbc.com returns similar results.

share|improve this answer
    
ya, you're right I can ping them now that I changed, the webpage still doesn't resolve. –  O.O Mar 27 '11 at 21:59
    
@subt13 - which browser are you using? Have you tried clearing the cache, checking the proxy settings etc, or indeed using a different browser. –  ChrisF Mar 27 '11 at 22:00
    
firefox 3.5.11 and IE 7. Yep, tried that. –  O.O Mar 27 '11 at 22:02

The inability to browse certain websites is a classic symptom of your MTU setting on your router being too high. It might not be what is causing the problems in your case, but it is definitely worth looking into if all else fails.

MTU is discussed in great detail on kitz.co.uk along with a tool called DrTCP which you can download to tweak the settings on your computer.

DrTCP will attempt to calculate out the best MTU setting for you. You would then have to hop onto your router's web interface and change the setting.

share|improve this answer
    
I have no router. I have a crappy qwest modem :P –  O.O Mar 27 '11 at 22:04
    
Hmmm if you don't have a web interface or telnet ability with instructions to use it, try running the test at dslreports.com/tweaks and try the DrTCP tool on your computer anyway. –  Kez Mar 27 '11 at 22:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.