Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accidentally disabled my D-link router's web interface. I installed dd-wrt firmware on it. The router's SSH and telnet connections are disabled. I don't want to reset the router.

How can I enable the web interface?

share|improve this question

migrated from serverfault.com Mar 27 '11 at 23:06

This question came from our site for professional system and network administrators.

    
Head: What if there's also no access via https? Only hard reset? –  Mokubai Nov 20 '11 at 11:25

2 Answers 2

Ok..I got it.. I access it over https..and entered username and password.

Keep in mind,there are protocols (http and https) that router used to display its web-based interface.

thank you guys..

share|improve this answer
5  
Feel free to mark this as accepted. You won't get rep, but it does let the system know it has an accepted answer, and future goolgers will be able to find it faster. –  SysAdmin1138 Mar 27 '11 at 21:02

SSH and then:

nvram set remote_management=1
nvram set http_wanport=8080 
nvram set httpsd_enable=1 
nvram set https_enable=1
nvram set remote_mgt_https=1 
nvram commit 
reboot 

Then connect:

https://wanIP:8080/

share|improve this answer
4  
He mentioned that SSH is disabled. –  Vick Vega Mar 27 '11 at 15:19
    
SSH is not enabled.. –  Sanyprashant Mar 27 '11 at 20:53
    
This is still very helpful if you have ssh enabled, though. –  Ehtesh Choudhury Feb 21 '12 at 4:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.