Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Outlook 2007 and I got an account on our company Exchange server. When I click the big Contacts button in the lower left, I can see all contacts I've created the last couple of years. But when I write a new email and click on the To-button to search/select contact from the Global Address List, I only see my co-workers and contacts in the exchange list.

It's pretty annoying and I'm sure I once, a couple of OS-upgrades and Office-upgrades ago, could search contacts as well. Was I dreaming?

Added more info: I've tried the "Outlook Address Book" tab on Contacts->Properties, but the option for "Show this folder as an e-mail Address Book" is unavailable/grayed out!

More info: I have used Windows Easy Transfer to move stuff from an existing account. I've found some info on the Internet that might suggest my Outlook account/profile or something might have become corrupt because of this and that's the reason why my contacts are not listed in the Address Book. If this is so, I'd love to know how to fix this in an easy way if possible. Perhaps a simple export import?

share|improve this question
    
Is there a "Show Names From:" drop-down like there was in Outlook 2003? –  Mark Aug 20 '09 at 11:28
    
@Mark - not that I can see. Sorry. –  user7094 Aug 20 '09 at 11:41

6 Answers 6

Make sure the Outlook Address Book is installed by doing the following:

  1. On the Tools menu, click E-mail Accounts.
  2. Under Directory, click View or change existing directories, and then click Next.
  3. If Outlook Address Book is not listed, click Add.
  4. Click Additional Address Books, and then click Next.
  5. Click Outlook Address Book, and then click Next.
  6. Click Finish, and then restart Outlook.

Once the Outlook Address Book is installed, you may also have to enable use of your Contacts as an Outlook Address Book. To check this, right-click on the Contacts folder, go to Outlook Address Book, and make sure the "Show this folder as an email address book" is ticked (and optionally set the name). If you have not followed the above steps 1 to 6, then this option will have been disabled.

Then when you open the Outlook address book it should appear in the "Address Book" drop down list with the name you specified in the previous step.

If that doesn't help, try some other troubleshooting steps located here:

http://office.microsoft.com/en-us/outlook/HP052421351033.aspx

share|improve this answer
    
Under Tools->Accout Settings->Address Books I got the standard "Outlook Address Book" listed already. Sorry... –  user7094 Aug 20 '09 at 11:40

When you click the To button you should get the select names dialog box. At the top of that window there should be a drop down named Address Book. The first thing in the list, which is not selected, should be your outlook address book. What's selected and appears under that in the list, is the Global Address List.

share|improve this answer
    
Yes, but my own contacts are not available in any of those lists –  user7094 Aug 20 '09 at 13:57

Make sure that your contacts are set to show as an address book. To check this, right-click on the Contacts folder, go to Outlook Address Book, and make sure the "Show this folder as an email address book" is ticked (and optionally set the name).

Then when you open the Outlook address book it should appear in the "Address Book" drop down list with the name you specified in the previous step.

share|improve this answer
    
Unfurtunately this option is grayed out :( –  user7094 Aug 20 '09 at 13:56
up vote 0 down vote accepted

It seems that this was/is due to my profile being migrated from an old computer to a new one, and when I used "Windows Easy Transfer" (is it called that?) something with my contacts and outlook/exchange went wrong. I've heard the same thing from someone else so...

Thanks for all the tips and such though!

share|improve this answer

Try to reimport contact and make sure to map field with target outlook field when importing. some time outlook does not map fields automatically.

share|improve this answer

If this is Outlook 2010 then you can resolve the problem as follows:

  1. Click the Home tab in the ribbon bar.
  2. In the Find section of the ribbon bar click the Address Book icon.
  3. Click the Tools menu.
  4. Click Options....
  5. Click the "Custom" radio button option. Make a note of the current setting first - likely "Start with Global Address List".
  6. Click the Add... button
  7. Under Outlook Address Book click to select Contacts.
  8. Click the Add button. If you changed the address list order to Custom in step 5 you can now change it back to the original setting if you want.
  9. Click the OK button.
  10. Close the Address Book.
share|improve this answer

protected by slhck Sep 8 '13 at 11:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.