Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed scim IME in my ubuntu 10.04 linux. I also installed hindi and gujrati support/fonts from System->Administration->Language support.

I logged in and logged out.

However, I have no clue how to use scim. I type scim, and some icon shows in the tray. I don't understand much of options in the menu. And I tried a document in openoffice or a file in gvim, but cant find any way to type in hindi. In openoffice, I tried some hindi fonts but they all type in english.

please tell me how to use scim!

thanks

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Most IMEs require you to press a specific keystroke to activate them; check the SCIM configuration to confirm what it is. Also, you may need to use another tool in order to enable the IM for the entire session, but I don't know what it's called in Ubuntu.

share|improve this answer
    
thanks.. I was missing the keystroke (Ctl + space) in case of scim.. I thought starting scim is all that is needed. –  anon Mar 29 '11 at 4:50
add comment

After installing the following package:

sudo aptitude install libkmfl0 libkmflcomp0 kmflcomp scim-kmfl-imengine 

Run

 scim-setup

Expand the "IMEngine" and click KMFL

Click on "Install" and browse to the folder where the compiles keyboard layout files reside

Open text editor press Ctlr + space to select your installed language

share|improve this answer
    
thanks... could not find KMFL... but, the activating keystroke/shortcut + rebooting after installation worked... –  anon Mar 29 '11 at 4:49
    
yes.. actually what I was missing was that I need to press some keystroke to activate it.. solved it before reading your answer, hence accepted his... thanks for yours too though as it would solved it as well –  anon Mar 30 '11 at 6:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.