Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I attempt to open links in IE8 on a Windows 7 PC the tab launches but the web page does not open. This has only started happening in the last week and no obvious software changes have been made. It also happened once before and I ended up re-imaging the PC.

I have tried the following:-

  • Deleted Temp Files and Cookies
  • Disabled all addons
  • Reset the browser
  • Created a new user profile
  • Internet Explorer (No Addons)
  • Upgrade to IE9

I have now run out of things to try. I need to use IE8 and IE9 as they are the only browsers compatible with the help desk software that we use.

Can anybody think of anything else I should try other than re-imaging the PC again?

share|improve this question
up vote 1 down vote accepted

You might have a look at How to Fix ‘Open in New Tab/Window’ problem in IE8.

The method is to re-register the following DLLs:

regsvr32 actxprxy.dll
regsvr32 shdocvw.dll
regsvr32 mshtml.dll
regsvr32 browseui.dll
regsvr32 jscript.dll
regsvr32 vbscript.dll
regsvr32 oleaut32.dll

The same solution, but in registry (.reg) format is offered here.

Another reported fix is found in: Repair IE8 (IE7) and IE9.
The script there fixes the open in new tab or window not working, among other symptoms.

share|improve this answer
Three of those commands fail, shdocvw.dll, mshtml.dll & browseui.dll The error is [Window Title] RegSvr32 [Content] The module "browseui.dll" was loaded but the entry-point DllRegisterServer was not found. Make sure that "browseui.dll" is a valid DLL or OCX file and then try again. [OK] – liamog Mar 28 '11 at 15:26
Added another possible fix. I do hope you have created a system restore point, just in case. – harrymc Mar 28 '11 at 15:45
Will try tomorrow and tell you how it goes. – liamog Mar 28 '11 at 17:31
The last repair worked. Thanks for the help – liamog Mar 29 '11 at 7:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.