Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an iMac with a second monitor (VA2431w) connected to it. The monitor was working fine, however today when it is turned on the screen appears to be green. The mouse and windows can move from one screen to the other without incident, however when items are viewed on the second monitor they appear green. The cable (DVI) that is connected to the monitor appears to be working fine and is firmly connected to the iMac. Does anyone know what could be the reason for this? I will try to connect the monitor to another computer soon to see if it makes a difference.

share|improve this question
1  
Any of the DVI connector pins out of place? –  Daniel Beck Mar 28 '11 at 17:39
    
Not that I can tell, they all look like they are there okay, but I will take another look. Thanks –  Alos Mar 28 '11 at 17:41
    
Same computer/different screen would be just as useful as same screen/different computer. –  Daniel Beck Mar 28 '11 at 17:42
    
Yeah I plan on doing that too, my boss is currently using the computer, but I plan to try that as well in about an hour. Thanks –  Alos Mar 28 '11 at 17:44
    
You were right Daniel, could you post the pin suggestion as an answer so that I could give you credit? Thanks –  Alos Mar 28 '11 at 18:02
show 1 more comment

2 Answers 2

up vote 3 down vote accepted

It's most likely (heh) your cable: Check the pins at the connectors if they're bent, or some are missing.

share|improve this answer
    
+1 and a thank you. Cheers –  Alos Mar 29 '11 at 18:46
    
DVI carries each color channel on a separate pin, so if the entire screen is hued a single shade it's almost always the connector. (Generally you see green or pink.) –  Shinrai Jan 25 '12 at 16:30
add comment

I had the exact same issue. I was using an LG flat panel/flat screen monitor (or TV, rather) as my external monitor. The TV was working fine and even the menu screen popped up in full, regular color. It was just the picture of my iMac desktop in the background that was green.

All i did was simply use a paperclip to reset the TV (not the iMac) in the back of the TV. Simple as that. The TV turned off and then when I turned it back on it was fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.