Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created a tar on a solaris box. The result was a 55.2 gb tar file. I used the following command to create the tar archive:

tar -Epcvf filename.tar ./directory_name

Now the problem is, when i try to untar it with root after entering this command

tar -xvf filename.tar

I am returned at the command prompt immediately. i.e., no untar happens.

On similar lines, I created another tar of a different directory. This time the tar size was ~15 gb. I did not face any problem untarring this one.

Why would untar fail for the 55gb archive and did not produce any error for 15gb archive?

share|improve this question

4 Answers 4

Never mind. gtar was already present in that box. I ran the following command as root,

/usr/sfw/bin/gtar -xvf filename.tar

But this command did not actually extract any content from the tar. It ran for around half an hour listing the contents of the tar. It did not actually extract. I created the original tar with a simple tar and now I am extracting it with gtar, could this be the reason behind this? If this IS the reason, then is there any way I can extract the content of the tar with a normal tar?

share|improve this answer
    
On what OS are you trying to extract the tar file ? –  jlliagre Mar 29 '11 at 15:59
    
Please use the Post answer button only for actual answers. You should modify your original question to add additional information. –  BloodPhilia May 24 '11 at 21:02

Did you use GNU's version of tar ? If not, please do so, that might solve your problem. A walktrhough of installation of gnu tar is here : http://sunsolarisadmin.blogspot.com/2007/03/how-to-install-gnu-tar-in-solaris.html

share|improve this answer
    
I did not use GNU tar. I installed GNU tar with the instructions. It installed tar in /usr/local/bin as tar (should that be gtar instead?). Now when I run /usr/local/bin/tar, i get, ld.so.1: tar: fatal: libintl.so.8: open failed: No such file or directory –  zatka Mar 29 '11 at 9:04

The difference to GNU tar should be -E (large file support, microseconds) and -p (restore files to their original mode). AFAIK the -p is used in combination with x, not c. I see two possible problems: lack of rights and symlinks.

share|improve this answer

You might try star which should be able to automatically read most if not all tar variants.

http://freshmeat.net/projects/star

http://cdrecord.berlios.de/private/star.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.