Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am looking to provide almost a... VPN of sorts... for my company. I can setup a reverse proxy for external people to get into our web apps with Squid. That's no problem. I can even setup stunnel on both ends to encrypt the traffic. (I could use SSH just about as well.) What my boss would like me to do, however, is not require any sort of tunnel.

I finally found and tried glype. I stuck it in an apache SSL server, and this is just about perfect, but one of the webapps that users will need to use gets gutted while passing through it, and won't work. (I've tried NOT stripping scripts, of course, but this has no effect.)

Am I missing a better way to do this, besides just giving up and trying (again) to setup an OpenVPN server? ;-)

share|improve this question

Why not use Squid's SSL support? This configuration example explains how to set up three websites as a reverse proxy encrypted with SSL using a wildcard certificate, but can be easily adapted to other situations.

share|improve this answer
Because squid's SSL support is limited to proxying sites that already have SSL enabled. It won't wrap everything with SSL, which is what I want. (I tried recompiling the package under Ubuntu, just to be sure.) – David Krider Mar 28 '11 at 20:49
@David: Squid supports both pass-through SSL and handling all of the SSL itself. The instructions I linked to explain how to configure the latter. (You were correct in recompiling squid, it seems that Ubuntu does not include SSL support by default.) – Patches Mar 28 '11 at 21:03

Check out Adito SSL VPN (a.k.a. OpenVPN ALS) It's written in Java and relies on a downloadable-on-the-fly Java applet to do the tunneling on the client end. You can create tunnels from the server that are launchable easily by clicking on a link.

Not the easiest thing to set up but works great for me.

share|improve this answer
This is very tempting. It seems like exactly what I'm looking for, but I've spent a day at it, and I can't get it to work on Ubuntu 10.04. I get exactly this error, but I can't find a solution. – David Krider Mar 30 '11 at 12:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.