Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I need to connect to something in my company I get a dialog like this

enter image description here

So I type in my password(this can popup when I am in IE 9 or outlook or whatever.) and check the box. Say I am in IE 9 I can close done IE 9 and reopen it and go to the page I just was and it will come up with the same box.

It is like it never remembers that I said "remember my credentials".

Anyone have any ideas what the cause of this could be?

share|improve this question

OP asked this question elsewhere and has been given an answer that works for me. That is:

  • Go to Control panel -> User accounts -> Manage your credentials
  • Select the credential in question
  • Delete it
  • Click "Add a Windows credential" for Windows Credentials, or one of the other categories.
  • Input host, login and password
  • Persistence of your login has changed to enterprise - will bet kept on logoff.

Somebody, please fix menu namings in my answer for them to be useful for English speaking people.

share|improve this answer
    
Worked. I don't know why you have to access the "credentials manager" through "user acounts" and add/edit/remove the password there - but it did work. Thanks! – lorem monkey Dec 18 '13 at 9:02

Is it possible that you already saved the wrong password for this account? (Maybe the password changed?) Try going into the password settings and deleting any saved credentials for the account and starting over:

http://windows.microsoft.com/en-US/windows7/Remove-stored-passwords-certificates-and-other-credentials

share|improve this answer
    
I will check but everything is setup by exchange so not sure if that will make a difference. – chobo2 Mar 29 '11 at 1:56
    
errr I mean active directory. – chobo2 Mar 29 '11 at 14:34
    
I deleted them and reentered them but nothing. – chobo2 Mar 30 '11 at 16:02

This one seems to have caused problems for a wide range of people, and not just on Windows 7.

This solution worked for me in testing (found it on a Microsoft Technet forum):

  • Go into Outlook - File - Info - Account Settings
  • Double click the Exchange Account - More Settings - Security Tab
  • Check "Always Prompt for Logon Credentials"
  • Close Outlook
  • Start Outlook
  • Go to login box and enter username and password
  • click on Remember my Credentials
  • Close Outlook
  • Start Outlook
  • Go to login box and enter username and password
  • Click on Remember my Credentials
  • Go back into More Settings - Security Tab
  • Remove the check from the "Always Prompt for Logon Credentials"
  • Close Outlook

However - It is not a good idea to do this! You should have to enter it every time, otherwise if someone steals your laptop you have made it that much easier to get access to your emails!

share|improve this answer
    
I have outlook 2007 I don't see Account settings. In the file menu. – chobo2 Mar 29 '11 at 15:49
    
Ok I think I found the page you are talking about. I did that but it still seems to pop up. I am not sure what you mean my repeat so maybe I did that wrong. As for someone stealing my laptop I am not too worried I am using truecrypt with a very strong bootup password. – chobo2 Mar 29 '11 at 15:55
    
m- This does not seem to have worked. I still get every single time. – chobo2 Mar 30 '11 at 16:06
    
Doesn't work for me. – md1337 Nov 5 '12 at 17:08

This works for me;

  • Go to internet explorer options
  • Add the site to the trusted sites
  • Set the security level for trusted sites to low
share|improve this answer

If you are like our company, some internal sites cross boundaries, and it will always prompt for credentials when crossing boundaries like firewalls, because windows authentication credentials are not being passed automatically across the boundary.

You may or may not get the network guys to update this. If not you can use a browser that remembers credentials independently. I have the same issue in chrome, but at least chrome remembers the credentials, and I just have to submit them with a button click instead of entering them again from scratch.

share|improve this answer

I had the same problem for a long while, but tonight I seem to have solved it. This is how I did it. Hope it works for you and many others. My network storage is Buffalo Linkstation LS-CHL (I will call it LS-CHL below).

Sign-in your network storage device manually as before.

Go to Credential Manager under Control Panel-User Accounts. Look for your network storage device under windows credential and open it. Then select Edit. Replece the domain name in front of your user name (LS-CHL, in my case). Save.

Log off from you Windows account and then log in again. Windows will again say it cannot connect network drive. Open Credential Manager again and you will notice that your device is not there under windows credential.

Now connect your device again manually. Then in Credential Manager click "Add a Windows Credential": enter device name (LS-CHL, in my case) as internet/network address, user name (without domain name) and password. Save.

That is it. Log off window and then log back on, your device should be connected automatically.

The sequence is important.

share|improve this answer

If you are on a company Intranet, check to see if you are in the correct OU , and make sure that Group policy is set up correctly

share|improve this answer

None of these aforementioned methods solved my Win7 remembering credentials problem. However, after many trials, I discovered that the problem was caused by the remote device's computer name coinciding with one of its local user names! I changed the computer name to something different than all of the local user names, then entered my remote credentials and enabled "remember my credentials" once again. After that Win7 never asks me again to logon for access to the remote computer.

share|improve this answer

SOLVED

We are working too hard to fix this... after exhaustive searches, I ran across my note where I have fixed this problem multiple times. It's real easy.

In my case, my workstation is called: Sam and my computer is USER03

The computer on the network I am trying to access is: SOUTHHALL

If I try to log in (simply log in Sam and then my password) and check the remember, it saves in the credentials as:

Internet or Network Address: SOUTHHALL User Name: USER03\Sam Password: *********** Persistence: Logon Session

You need Persistence to say: Enterprise instead of Login Session. Here is how to fix it:

Delete the credentials and add it (in the same place Windows Vault) as:

Internet or Network Address: SOUTHHALL User Name: Sam Password: ********

And it will now save it as Enterprise.

All that you did was remove your computer name of USER03.

I think this has been everyone's problem including mine since we think the syntax that windows creates must be the right syntax. It doesn't need the machine name, only the user.

Let me know if this works for you. I've used it on about 5 workstations and it has worked for me, but I forgot the solution, which turned out to be easy.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .