Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some PDF's which, when I double-click to open, automatically bring up the Print dialog box in Adobe Reader X. I'm on Windows XP. I think this is because of some code within the PDF itself. Is there some way I can disable such automatic printing from Adobe Reader?

share|improve this question
up vote 9 down vote accepted

If it's happening only with some specific files then it's probably because:

You can tie Acrobat JavaScript code to a specific PDF document, a page, field, or button within that document, or a field or button within the PDF file, and even to a user action

You can disable javascript in Adobe Reader:

  • Open Edit -> Preferences
  • Click on Javascript on the left-hand pane
  • Uncheck Enable Acrobat Javascript on the right-hand pane
share|improve this answer

Open in Adobe Acrobat. Goto tools > Javascript > choose "Document Javascripts". Then a dialog box pops up. There will be this.print() code with a corresponding script name (0 in my case). Just press delete botton in the dialog box and save.

share|improve this answer
3  
Can you do this with Adobe Reader, or do you need the full Acrobat version? – wisbucky Jan 25 '14 at 22:41

Try to re-create (or re-print) the PDF file using PDFCreator.

share|improve this answer

Open the Document Properties in Adobe Acrobat (Ctrl+D) and make sure that no toolbars or window controls are hidden in the tab Initial View.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .