Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In gconf-editor I can set hotkeys for switching to a specific workspace/viewport when using metacity. I'd like this functionality too for compiz, bit did not find it so far. What I want is: Super-F1 switches to workspace/viewport 1, Super-F2 to workspace/viewport 2 etc.

How can I do this? (BTW: I am using ccsm with gconf-backend)

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The keybindings set in /apps/metacity/global_keybindings/switch_to_workspace_X with gconf-editor should continue to/also work with Compiz. You can also use CompizConfig Settings Manager to set them. Just select Viewport Switcher from the Desktop area, and switch to the Go to specific viewport tab.

(I actually set one with CCSM to verify that it still used the bindings in /apps/metacity/.)

share|improve this answer
    
Thanks for the information. Unfortunately I do not have a Viewport Switcher in the Desktop area. just "clone output", "desktop cube", "desktop wall"(enabled) and rotate cube. I'm using Fedora 14 if it's relevant. I'll look around whether there is a viewport switcher elsewhere (maybe in some exotic rpm package...) –  mawimawi Mar 29 '11 at 12:49
    
@mawimawi: Does manually setting the keybindings in gconf-editor work? What Linux distribution/version are you running? –  Patches Mar 29 '11 at 12:54
    
as written before: Fedora 14. The "Viewport switcher" was not installed on my system, I had to search for other compiz-rpms and installed compiz-fusion-extras, compiz-fusion-unsupported, compiz-fusion-extras-gnome and compiz-fusion-unsupported-gnome. Somewhere in these packages there was the Viewport Switcher, so everything's fine now. Thanks again for you info! –  mawimawi Mar 29 '11 at 12:58
    
@mawi: Sorry, I don't know how I missed that. Glad you got it working! –  Patches Mar 29 '11 at 13:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.