Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My workstation with Windows7 professional is a member of a domain. I have local administator priviledges, and a separate account with standard privileges as every other user in company.

I need to switch between the two accounts while working, but the "Switch user" button is disabled, and there is no "switch user" option after pressing alt+ctrl+del.

I have seen Can 'Switch User' in Windows 7 work with Active Directory? thread, but there is nothing useful apart that it can be done.

I have checked out gpedit.msc and Hide entry points for fast user switching in Local Computer / Administrative Templates / System / Logon is set to Not configured, but I tried both enabled and disbaled without success.

I have checked out services.msc, as I read that fast user switch compatibility service should be enabled and running. The thing is there is no such service. It is not disabled, or something. There is no such entry on the list.

How to enable this functionality? Can I do it alone, or my Active Directory administrator have to set some options on domain controller? Is it possible in mixed XP / Win7 domain?

P.S.: I have Polish version of Windwos, so I have translated the names of options and service to english, and I might translate it not exact. The service name in Polish should read Zgodność szybkiego przełączania użytkowników, but there is no such service.

share|improve this question
    
I think the main problem is the lack of fast user switch compatibility in services.msc, but I do not know how to make it appear there. –  SWilk Mar 30 '11 at 8:21

3 Answers 3

Generally, a standard part of a domain setup includes the disabling of this ability. Fast user switching is primarily used for home computers and your domain administrators, rather than using a Group Policy settings, simply remove the system service to prevent work arounds.

I have not seen a managed domain that allowed fast user switching.

You can use Run As for many tasks that require elevated permissions. Some installations will fail when you do this, but many others will work.

I'd talk to the IT group and ask if this is what they've done.

share|improve this answer

If you have installed any Cisco software on your computer, that might explain it. Both Checkpoint and their VPN software disables fast user switching. That was how my entry was greyed out.

share|improve this answer

If your computer is on a domain, you can turn Fast User Switching on/off by performing the following:

1.Click the Start button Picture of the Start button, type gpedit.msc in the search box, and then press Enter. Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

2.Under Computer Configuration, click the arrow next to Administrative Templates, and then click the arrow next to System.

3.Click the Logon folder.

4.Double-click Hide entry points for Fast User Switching Properties, click Enabled, and then click OK.

share|improve this answer
    
I tried it earlier but no success. I tried both setting disabled and enabled. If I understand correctly, this sholud hide or show the Switch user menuitem, but the item is where it should be, but disabled (greyed out). –  SWilk Mar 30 '11 at 8:19
    
and if its disabled by Group policy it'll just revert right back to how it was at every domain logon. –  Joe Taylor May 28 '12 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.