Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP Elitebook 8440P running Windows XP Pro SP3. I installed it on my docking station and everything went smooth for a while. Last week, my mouse and any other USB devices stoped working sudenly... It was working fine on my laptop itself but nothing on my docking station. LCD attached monitor works and same for LAN and PS2 keyboard.

I updated the BIOS, Chipset, Video Drivers, also changed my docking station by a brand new one but the problem still comes back.

I also noticed something in Device Manager... A Generic USB Root Hub has an error on it, a Yellow/Orange exclamation mark. I tried to update that driver but no luck. Windows is unable to process it. This seems to be the problem but can't fix it. I may only re-image my laptop but for me, I need to avoid that since I have so many apps installed on it.

If anybody has any advice, I'll take it!

share|improve this question
    
I've got the exact same issue under Windows 7 and couldn't find a solution since a couple of months. The weird fact is that it works, sometimes! My only workaround when it happens is to plug my keyboard and mouse to the laptop's USB ports. –  user100066 Oct 3 '11 at 15:38

1 Answer 1

I've fixed it by doing a proper system shutdown and re-seating the hard disk drive.

I had a customer with an EliteBook 8440p (Core i5, 4 GB of RAM, Windows 7 64-bit on an SSD) that had the same problem. I had rebooted to no avail, then I put the hard drive in a swap machine (another 8440p). Tested good, but the customer still wanted her original machine. So I put the hard drive back into the original 8440p to continue troubleshooting, and the USB ports were functioning again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.