Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My neighbor is trying to search a pdf file for the word 'eight' but doesn't want 'weight', 'eighty' or other instances where 'eight' is within a larger string. She searched for ' eight ' (with spaces on either side), and it ignores the spaces. I just tried the same, and it ignores the spaces in the search.

How do you get the pdf search to not ignore spaces?

She has tried with a space before and after, both before and after; on Vista and Windows 7; with an Adobe reader and a reader/writer.

It seems like there should be a setting, and under Edit/Preferences, there is a Search option. But I sure don't see how to set it to not ignore leading and trailing spaces in a search.

share|improve this question
1  
What reader are you using? –  PriceChild Mar 29 '11 at 15:37
    
I'm using Acobe Reader 9, and I think she mentioned 9 as well. –  thursdaysgeek Mar 29 '11 at 15:41

3 Answers 3

up vote 8 down vote accepted

Select Edit > Advanced Search

Select "Match Exact word or phrase", then tick the "Whole words only" option.

Apparently this is only in Adobe Reader X (sorry).

In Adobe Reader 9 it's Edit > Search (Shift+Ctrl+F)

Adobe Search menu

There's no drop down but there is the "Whole words only" option:

Adobe Search options

share|improve this answer
    
Adobe Reader 9 doesn't have an Edit > Advanced Search. Under Edit, it has Search, Search Results, and Preferences. Preferences has a Search category, but nothing about "Whole words only". –  thursdaysgeek Mar 29 '11 at 16:25
    
The "Find" toolbar also has a drop-down menu (from the small arrow) that allows you to select "Whole Words Only". –  sblair Mar 30 '11 at 12:29

Most search engines will consider exact match if you surround the text with " like " eight "

share|improve this answer
1  
The OP has already tried that and found it didn't work. –  ChrisF Mar 29 '11 at 15:44
2  
I think laurent is suggesting to not just wrap in spaces, but also quotes. –  PriceChild Mar 29 '11 at 15:52
    
@PriceChild - Yes, exactly - I understood the OP has tried only with spaces –  laurent Mar 29 '11 at 15:54
    
If I surround the word with quotes, it finds nothing, because no words have quotes around them. That sounded like a good idea. –  thursdaysgeek Mar 29 '11 at 16:27

Keep your software up-to-date, Adobe Reader 9 has bugs and security leaks.

Here is a screenshot of Adobe Reader X:

enter image description here

As it looks like they slightly revamped the search engine it might support the " " syntax as well...

share|improve this answer
1  
I'll suggest to my neighbor to try the newer adobe, if that's an option for her. Both of us use what our companies provide, and at least for me, upgrading on my own is simply not allowed. –  thursdaysgeek Mar 29 '11 at 16:51
    
You could try to propose an upgrade if the feature is necessary for your work, another option is to use a portable version of Adobe Reader X. –  Tom Wijsman Mar 29 '11 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.