Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 7 laptop (Dell Inspiron) and I'm trying to simply listen to music through headphones. This process used to work flawlessly.

Something changed and now iTunes (as well as WMP and any other audio playing device) will not play through the headphones, which are plugged in. Instead, the music plays through the crappy laptop speakers.

The only thing I can see is that the music seems to be playing through the Speakers/Headphones playback device (seems reasonably named) but should be playing through the Independent R.T.C. Headphones, instead. This info comes from the Sound config area of the Windows 7 Control Panel.

The funny thing is that Skype uses my headphones just fine. I just don't know where to start looking to make sure the media players are using the correct audio when headphones are plugged in.

share|improve this question
up vote 0 down vote accepted

It is generally a hardware function on the laptop itself that automatically routes sound through the headphones if they are connected.

Have you tried different headphones?

If so, update your system BIOS (download is usually available from the laptop makers webpage). Also, check your BIOS settings for any obvious issues.

If you have some sort of specialized audio driver (RealTek is a common one) it may have settings that determine how the audio auto-routing is handled. Check for any obvious settings regarding where sound is sent when headphones are detected.

Also, download the latest audio drivers from your laptop maker website and install them. Even if they are the same version as your current drivers, reinstalling them may reset the settings to the default you're expecting.

share|improve this answer

Itunes --> Edit --> preferences --> play --> play audio with: windows audio session,

restart itunes and it will work again! :)

share|improve this answer

You could start looking at the lower, right part of your screen. Next to the clock you will have a small icon resembling a speaker. Right-click and you can enter the volume mixer. There you can adjust volume and output individually for every sound-producing program on your computer.

share|improve this answer

When you go to Itunes --> Edit --> preferences --> play --> play audio with:

you will see two options 'Direct sound' & 'windows audio session'

direct sound is the option to play sound from ear/head phones or external speakers(in case of a dock connection).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .