Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently purchased VPS and setup virtualmin with all dependencies. I can reach my website, and I can connect via SSH to the server, but I can't connect with ftp from my desktop.

When I'm using it's working fine, when I'm login via SSH to another VPS and then try FTP the first one - it's working fine.

So I've started to test different servers and different clients (ftp wanderer) from my desktop, non of them worked.

I've tried a different internet connetion (totaly different ISP, usb cellular modem) but it also didn't worked.

Then I've tried my virtual machine (VMware Workstation) with the usb modem and it suddenly worked! Both of them (phisical laptop & virtual machine) windows 7, and I've temporarily turned off windows firewall and ESS firewall in both.

I've tried another 2 PCs but no success...

When I'm trying to ftp via cmd it's just can't connect without saying nothing:

C:\Windows\system32>ftp 69.x.x.x
Connected to 69.x.x.x.
220 ProFTPD 1.3.3d Server (69.x.x.x) [.....]
User (69.x.x.x:(none)): <Here I typed my username>
331 Password required for <username>
Password: <I typed my password>
230 User <username> logged in
ftp> pwd
257 "/home/<username>" is the current directory
ftp> ls
200 PORT command successful
150 Opening ASCII mode data connection for file list

And here it's just hang, wait forever...

What could be the problem?????

BTW, I've seen the following questions, didn't helped.

  1. Can't connect to FTP sites
  2. Unable to connect to FTP sites even with Windows Firewall disabled
share|improve this question
weird, I was able to connect fine (btw, probably should edit your post and remove the IP address, it's inviting trouble). Maybe try specifying port 21 (though I'd think it always tries that first)? – CreeDorofl Mar 30 '11 at 1:30
@cree Thank you, I've used many clients so at least part of them if not all tried port 21 first – dvb Mar 30 '11 at 2:54
That's pretty strange. Can you try "telnet 69.x.x.x 21" and see if it connects that way? Also, when you switched ISPs, did you plug the computer into a different router, or did you plug your router into a different device? – emgee Apr 7 '11 at 7:39
@emgee with telnet, I'm able to connect to my home dir, and even execute some commands (… ) but I can't LIST the files in the directory. I'm just receiving '425 Unable to build data connection: Invalid argument' – dvb Apr 7 '11 at 10:27
That makes sense you as can't do much with telnet -- with FTP transfers go over a different port and telnet won't listen on these. Not that this data gives me much to go off of. – emgee Apr 7 '11 at 10:29

This thread might help : Virtualmin Backup to FTP Server | passive ftp connection problem

Q: When I schedule a backup with Virtualmin (3.79 GPL-1) to backup the files to a (Windows 2008 SP2) FTP server, the backup fails. This is because Virtualmin uses a passive FTP connection, which won't work because this FTP server is behind a firewall and only ports 20-21 are forwarded to the FTP Server. A connection is established (on port 55xxx i see in the backup logs) and times out after that because of the used port. When I use a FTP client on my notebook, on the same network, I notice the same. Only non-passive connections work, with passive FTP connections it times out on the directory listing.

Opening/forwarding ports from 49000-65535 is not an option in this situation. Is it possible to setup Virtualmin to don't use passive FTP, but only ports 20-21? When creating the backup schedule filling in the IP address like: is not possible, the ':21' is removed after the schedule is saved.

A: you'd probably be better off to install ssh on your WS2008 box.

The explanation as to when it works or doesn't may be as simple as whether the FTP connection is made in active or passive FTP or instead through SSH.

Apart from this, you could try Fix for Filezilla Failing to Retrieve Directory Listing.


  1. Have you tried Core FTP Lite, downloaded at Core FTP LE 2.2 : free version ?
  2. Have you tried to disable all firewalls and antivirus products on your computer?
share|improve this answer
thanks, but I've tried many (s)ftp clients with passive or active mode, none of them worked. – dvb Apr 7 '11 at 10:11
One point I didn't get here is whether it (1) always works with the USB cable, or (2) only works with the USB cable if the first connection is done via the VM then a connection from the host also succeeds. – harrymc Apr 7 '11 at 11:12
I'm not sure I understand you... in my laptop it doesn't matter which connection I use, it's just connect but can't list files so ftp clients hang after this command – dvb Apr 7 '11 at 11:16
Your question is very hard to understand. If you want us to comment intelligently on your problem, please re-paraphrase it. The desktop/laptop conditions etc. You need to clearly describe your experiments and under which conditions they work or not. With the current text, we are just guessing. – harrymc Apr 7 '11 at 12:09
As long as the question isn't cleared-up, I am treating it as "cannot do directory listing". So I added some more info above. Please always test both active and passive modes and turn off all firewalls. – harrymc Apr 7 '11 at 16:49

Welcome to the not-so-well documented world of active & passive FTP. Here's a good read to kinda point you in the right direction:

share|improve this answer

Ok, some things to try:

1) Check Internet Options in your Control Panel and see if there is a system-wide proxy set for FTP.

2) Check your router if there is some sort of outgoing block on FTP ports — both 20 and 21. I know you tried more than 1 ISP, but if for some reason the same router was used for both, this is a possibility.

3) Switch to SFTP instead, as it's secure :)

share|improve this answer
1. There is NO proxy configured, 2. the usb modem has no router, 3. currently I can only connect via ssh, no ftp, no sftp. of course once I'll ba able to connect I'll use sftp – dvb Apr 7 '11 at 11:09

Try running the ftp command with -d for debugging and before you run ls try changing the transfer mode to binary

share|improve this answer
up vote 0 down vote accepted

Just wanted to share in case anyone wonder that it has been suddenly fixed without anything I've done to solve that.

Long afterwards, I found that the issue was with my ISP. They were filtering connections and blocking some of them.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .