Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am setting up a computer to be a server for backup usage. I bought a 500 GB SATA hard drive and replaced a 50 GB PATA harddrive with it. I disconnected the cables which were connected into the old HD and plugged the new SATA harddrive into a plug on the motherboard names "PRISATA" or something like that, I assume meaning "PRIMARY SATA". I also connected the power cable to a matching connector.

So I inserted my debian CD and booted it. Debian detected the 500 GB harddrive and installed to it successfully. I also told it to install the GRUB bootloader. At this point, I restarted the computer. However, the harddrive was not detected and it gave me an error. I restarted and entered BIOS and found that the HD was not detected, only the CD drive.

What am I doing wrong here?

share|improve this question
Is it possible you've got a GUID Partition Table (GPT) on your new hard drive instead of a Master Boot Records (MBR), and your BIOS is too old to know about GPT? – Spiff Mar 30 '11 at 2:21
Instead of editing the question to say this is solved, you should mark the answer you provided yourself below as the accepted answer. – 8088 Mar 30 '11 at 16:02

The BIOS needs to see the hard drive in order to tell it to boot. Debian can interrogate the controller to get the hard drive info. I'd check the BIOS and see if there's a setting for to enable the controller. It may be thinking that the IDE interface is the primary one.

share|improve this answer

It turns out the problem was that RAID (Redundant Array of Independent Disks) was enabled. When I disabled the option in BIOS it booted just fine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .