Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mounted restoredb directory to my OS X 10.6.2 via Disk Utility with Advanced Mount Parameters = resvport.

I am able to edit files that are in the mounted directory but I am not able to create new files.

Any idea how to fix that? I can create files if I look as root

/etc/exports on nfs server (testing)

/srv/www/htdocs/restoredb       10.0.0.210(rw,no_root_squash)

mount on OSX gives me this output

 map -static on /Users/radek/Sites/restoredb (autofs, automounted, nobrowse)
 testing:/srv/www/htdocs/restoredb on /Users/radek/Sites/restoredb (nfs, nodev, nosuid, automounted, nobrowse)
share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to give yourself write permissions on the /srv/www/htdocs/restoredb directory in order to create or delete files.

share|improve this answer
    
before mount drwxrwxrwx 2 radek procview 68 30 Mar 09:34 restoredb –  Radek Mar 30 '11 at 6:20
    
after mount dr-xr-xr-x 2 root staff 1 30 Mar 17:20 restoredb –  Radek Mar 30 '11 at 6:21
    
ownwership and permissions above before I posted my question –  Radek Mar 30 '11 at 6:21
1  
@Radek You need to change permissions on the server. –  Daniel Beck Mar 30 '11 at 7:49
2  
@Radek The server admin sets up the permissions. AFAIK, NFS uses the Unix user IDs for that, so you need to figure out what user IDs have permissions, and change your local user accounts' user IDs accordingly. It's probably best to keep the users of both systems in sync somehow. Change OS X user account IDs in System Preferences » Accounts » Right-click an account » Advanced… (which is rather dangerous if you don't know what you're doing, I am told) –  Daniel Beck Mar 31 '11 at 5:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.