Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use PuTTY on Windows 7 to access a Linux machine with Ubuntu 10.10. I think that Windows 7 is using Latin-1. But I need to use UTF-8 on the Linux machine and in a PostgreSQL database.

How can I do this with PuTTY?

share|improve this question
up vote 5 down vote accepted

You can set PuTTY to use UTF-8 from the configuration dialog when you connect. Go to Window -> Translation, and set "Received data assumed to be in which character set" to UTF-8.

Also check that your locale is something ending in UTF-8 by running locale after connecting.

If it's not, run locale -a to see all the locales you have available. If there are no UTF-8 locales available, you need to configure your /etc/locale.gen, it's usually fairly well commented and it should be obvious what to add or uncomment. Then run locale-gen and check locale -a again to see the UTF-8 locale that was generated.

Something like export LC_ALL="sv_SE.UTF-8" ought to do the trick of actually setting the locale if and when it's generated.

share|improve this answer
    
@Jonas: That seems fine, UTF-8 locales all support the same symbols. sv_SE.UTF-8 is just the Swedish locale, whereas en_US.UTF-8 is the United States locale. In practice this only affects for example month names, date/time formatting and other minor stuff that varies by country. – jho Mar 30 '11 at 8:24
    
Thanks, just changing the setting in PuTTY: Window > Translate as you mentioned was enough. – Jonas Mar 30 '11 at 8:29
2  
Related: How to make the setting persistent. – grawity Mar 30 '11 at 10:50

The two basic factors are Window/Translation in putty and locale settings in Linux, as instructed here and many other places.

In addition, it may help in putty to set Connection/Data/Terminal-type string to "putty", and/or in Linux to export NCURSES_NO_UTF8_ACS=1. These two are also mentioned multiple places.

But: you may still get blocks for certain characters because the default fonts like Courier and Lucida Console don't have all unicode chars. Download and install http://dejavu-fonts.org/wiki/Download, and set putty to use it.

This last trick was necessary for me to get noping (recommended!) to show all graphic characters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.