Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu off of a live CD. Now, I cannot get the thing to show up. When I type "mount" I get this:

dcole@Ubuntu:~$ mount
/dev/loop0 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
/dev/sda1 on /host type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/dcole/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=dcole)

I am new to Linux, but I am pretty sure it is not showing up here?

edit:

also this:

dcole@Ubuntu:/$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/host/Ubuntu/disks/root.disk /               ext4    loop,errors=remount-ro 0       1
/host/Ubuntu/disks/swap.disk none            swap    loop,sw         0      

How come Ubuntu is not recognizing my dvd-rom drive?

share|improve this question

migrated from serverfault.com Mar 30 '11 at 14:45

This question came from our site for system and network administrators.

    
There's askubuntu.com, and unix.SE, both a better place for this question, I think. I'd recommend askubuntu.com. –  Jürgen A. Erhard Mar 30 '11 at 12:28
    
You can also check dmesg to see what dev it was given (ie /dev/sdc). –  thor Mar 30 '11 at 12:31
    
@jae, @Derek: please do not cross-post. If you would like your question moved, please flag for moderator attention and say so. –  studiohack Mar 30 '11 at 15:04

2 Answers 2

up vote 2 down vote accepted

ubuntu doesn't mount the Drive unless its necessary (i.e. a DVD or CD was loaded into the drive) .. did you check for that?

Also, if you already have a CD in there .. try this command in the terminal

mount /dev/sr0

or

mount /cdrom

and this should - in most cases - mount your DVD drive ONLY when there is a media loaded in, otherwise the command will just hang and do nothing ..

Those are the preliminary procedures to see if it works, if it doesn't, then it might be alot of other issues, but let's leave them till later, until after you try this one

share|improve this answer
    
I did make sure there was a CD in the drive and both of those commands give this: mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab –  Derek Mar 30 '11 at 13:11
    
ok, go into the /dev folder .. and look for the connection of the drive there, like cdromX, cdrwX, or sometimes srX .. where X can be any number .. (e.g. mine is cdrom2) .. Oh, and also, is the drive accessible on other systems? i mean if you have windows, or you can boot from it? –  msalem Mar 30 '11 at 14:49
    
Yes, the drive is accesible on other systems. I am dual booting with winXP, and in fact I installed ubuntu from this very drive. I did not see anything in the /dev folder though –  Derek Mar 30 '11 at 14:56
    
"I did not see anything in the /dev folder though" nothing at all?! or you mean nothing related to the cdrom ? i don't know, it seems a kernel issue, i have seen some reports of some guys having the same issues last summer on the ubuntu forum .. but up to no luck, see here: ubuntuforums.org/showthread.php?t=1348528 try looking around the net for maybe a linux driver for your drive? some do so because it can't/won't/still not included in the kernel, or may try your luck with a newer kernel .. kernel.org Sorry but that's all i know about this .. –  msalem Mar 30 '11 at 15:17
    
what's the make of your DVD drive BTW? –  msalem Mar 30 '11 at 15:18

Looks like the optical drive isn't in the fstab.

Try doing this:

cd / 
sudo mkdir TESTCD
sudo mount /dev/cdrom /TESTCD

If it works, you need to add your optical drive to fstab.

Try adding this line at the bottom of fstab:

/dev/cdrom  /mnt/cdrom   auto    noauto,user          0 0

/mnt/cdrom is the directory where the disk should be mounted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.