Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to compile git on an HP-UX system. and when i run make all, I get a syntax error on line 252. if i go to line 252 of the makefile, i see

uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')

I've tried a couple ways to correct this error, removing the line and changing it to a hardcoded value, but even if i comment the line, remove the line, change it, or anything else, i still get a syntax error on line 252. has anyone successfully compiled git on hp-ux without using the gcc compiler?

thank you!

share|improve this question

1 Answer 1

I have never used HP-UX, but on FreeBSD when I get these kind of errors it's invariably the version of make that is installed. BSD systems (and I think HP-UX is based on BSD) use the BSDMake (or pmake) program, whereas Linux uses Gnu Make.

You may like to try installing Gnu Make first and then using that to compile git.

share|improve this answer
    
can it be installed without root access? as i do not have root on this system. –  Chris Drappier Mar 30 '11 at 16:29
    
In HP-UK specifically I have no idea. You may be able to compile it from source - as long as it doesn't need GNU make to compile... (chicken... egg...) –  Majenko Mar 30 '11 at 16:32
    
I know right. Okay, not a magic bullet type answer that I was hoping for, but it is what it is. thanks for the reply :) –  Chris Drappier Mar 30 '11 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.