Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set a vncserver in my Ubuntu 10.10 Server, and started the service by vncserver :1, and I could also connect it from my Ultra VNC viewer on my WinXP.

Everything works fine, but I just cannot type the Key d.

Say if I am in a terminal, and I type d, the terminal window will be minimized, and if I type d again, it comes back.

Does anyone know how to fix this?

share|improve this question

migrated from stackoverflow.com Mar 30 '11 at 20:56

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 5 down vote accepted

I just got the solution by myself.

  1. Go to System -> Preferences -> Keyboard Shortcuts;
  2. Select the row Hide all normal windows and set focus to the desktop;
  3. Press Alt+D or any other combination;
  4. Kill your current vncserver connection by vncserver -kill :1;
  5. Restart it by vncserver :1;
  6. Re-connect it from your VNC client.

Problem solved.

Peter

share|improve this answer

Also you can use openbox as window manager instead of metacity for VNC sessions. Metacity shortcuts will not work, and Mod4+D does not break anything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.