Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to create a Word document with links to resources on the web. If I create a hyperlink to a regular HTML file, when I click on the link, it opens in my default browser (Google Chrome) as expected.

However, if I click on a link to a PDF file on a website, it opens in Internet Explorer. Before it opens, I also get the following prompt:

Microsoft Office

Opening http://www.example.com/example.pdf

Some files can contain viruses or otherwise be harmful to your computer. It is important to be certain that this file is from a trustworthy source.

Would you like to open this file?

OK Cancel

I'm using Office 2010, but I'm asking for a user who is using Office 2007 and is experiencing the same issue. (His default browser is Firefox.) We're both on Windows 7.

share|improve this question

3 Answers 3

Is the prompt coming from IE or as a security prompt from Word prior to opening IE?

This looks like the standard IE file download warning.

In his Adobe (Reader, Standard, Pro, etc) application, go to Edit -> Preferences.

In the Internet section, make sure the item for Display PDF in Browser is enabled. For greatest compatibility, I've also found unchecking (disabling) the Enable Fast Web View and Enable speculative downloading help make things work better.

share|improve this answer
    
The prompt is coming from Word (the title bar says "Microsoft Office"; I've edited my post accordingly.) "Display PDF in Browser" is enabled. I tried disabling it; when I did that, clicking on the PDF link in the Word document just caused a "Blank Page" tab to open in IE and the PDF did not open at all. –  Tweek Apr 1 '11 at 18:05
    
I am not, then, intimately familiar with this security function in Word. The verbiage is the same as the IE download warning, but if it's got the office title bar then I'm not sure. Try the instructions at this page and see if they work: office.microsoft.com/en-us/word-help/… –  music2myear Apr 1 '11 at 19:02

The warning, as mentioned is basically microsoft word trying to protect you from opening any suspicious files. As for why it isn't open in Chrome, that has to do w/your file associations. Your .pdf extension is associated with Internet Explorer and/or an Internet Explorer Plugin. your .html extension is associated with Chrome. Anyways... here's how you change it.

http://www.makeuseof.com/tag/change-fix-broken-file-type-associations-windows-7/

share|improve this answer
up vote 0 down vote accepted

I've discovered that the registry key change documented at http://support.microsoft.com/kb/218153 resolves this issue.

In summary, you need to create a DWORD Value called ForceShellExecute with a value of 1 in the following subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

If you are running a 32-bit version of Office on a 64-bit version of Windows, create the key here:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

Note that this registry subkey is the same for all supported versions of Office (i.e. don't create a key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\Internet just because you're using Office 2010 — it won't work.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.