Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using VLC to make some screenshot but, while playing the video the image is clear, when I take a screenshot (I'm using the snapshot tool inside VLC), here's the result:

blue-ish image in VLC

What am I doing wrong? If you need infos about the video (codec etc..) just tell me how to get them and I will post them.

EDIT #1

Here's codec information

enter image description here

EDIT #2

VLC Version: 1.1.8

share|improve this question
2  
smells like Pandoran ambiance ;) –  Mehper C. Palavuzlar Mar 31 '11 at 12:18
    
Can you post what you see in the Tools->Codec Information dialog? –  heavyd Apr 7 '11 at 2:30
    
@heavyd: is that what you need? –  dierre Apr 7 '11 at 13:16
    
How are you taking the screenshots? Print-screen key then paste into a program? It might be the program you are saveing the screenshot to does not support the pixel format that is being stored on the clipboard. Have you tried using Paint.NET to paste the images in? –  Mokubai Apr 7 '11 at 13:19
    
Are you using VLC's snapshot function? (I think it's Ctrl+Alt+S) If not, the cause of this problem is probably the fact that VLC renders its frames directly to the video card (overlay) for better performance. So using a screenshot tool might not work, I guess –  f3lix Apr 7 '11 at 13:31

1 Answer 1

up vote 2 down vote accepted

It looks like there is a long standing bug in VLC in handling RV24 video that might be the root of your problem. I would suggest using a different input format if you can.

To find out if you can change the input format open the messages window from the Tools menu and turn the verbosity up to 2. Now open your stream and once it starts playing stop it. Go back through the log messages a look for something along the lines of:

dshow debug: EnumDeviceCaps: input pin accepts chroma: RV24

If you see anything besides RV24 (maybe YUY2) , then you should be able to click on the "Advanced Options" when you setup the stream and set the "Video input chroma format" to one of the other values listed in theEnumDeviceCaps. If it doesn't give you any other options, you might be out of luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.