Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Pretty simple and very confusing. In order to get the @ to respond I have to hold it down for 1 second before anything happens and then delete all of the extra characters that have been typed. same goes ' obviously. It has nothing to do with shift.

I thought maybe it was my keyboard so I tried a different keyboard and the same problem and my keyboard in a different computer without any problems. This is hugely upsetting whilst trying to program anything..

Any ideas then?

share|improve this question

migrated from Mar 31 '11 at 14:05

This question came from our site for professional and enthusiast programmers.

What happens if you just press it once and let go? – Dan Puzey Mar 31 '11 at 13:31
I assume @ and ' are on the same key? Why do you say "same goes for ' obviously"? If they're not on the same key, does the non-shifted character on each of those keys work properly? – Cody Gray Mar 31 '11 at 13:34

You may have international keyboard where some keys are actually "dead keys". Those keys are meant to be combined with some other keys to produce new keys. Example: type ', then type e, and you should get é. You have two solutions

  1. Switch to more appropriate keyboard. I always use English U.S. for programming, even if keyboard is some other type. It's just easier to remember where all important keys are.

  2. After typing ' always type one space. Dead key ' + Space = live key '.

share|improve this answer

Check the keyboard "Repeat delay" in the Control Panel. Its likely set too high, try decreasing the delay time.

share|improve this answer
up vote 0 down vote accepted

Cheers for the answers dudes.

So i didn't have any other languages set but i went to 'Advanced Key Settings' ¬ Hot Keys for input languages ¬ action - Between input languages ¬ and the option 'Grave Accent (') was selected so i changed that to Not Assigned and it seemed to sort out my problem.

No idea

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.