Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Dell M1530 never seems to run at its full clock speed, regardless of the tasks I throw at it. To diagnose this I have my Dell M1530 configured to use 100% CPU clock speed at all times (regardless of whether it's plugged into the mains):

enter image description here

But when I run Windows' Resource Monitor app, it reports a "Maximum Frequency" of 31%:

enter image description here

Does this mean my laptop is running slower than it could? It's definitely running slowly. If in fact the CPU is being underclocked, is there a way I can force 100% clock speed?

BTW, here are temperatures during compile of some C++ code:

enter image description here

share|improve this question
Check the bios for a Intel setting you can change for "speed step" – Moab Mar 31 '11 at 14:41
You know that doing this will cut down battery life by more than half, and force your fan to run full-bore almost constantly? – Joel Coehoorn Mar 31 '11 at 15:11
@Joel I'm not sure that is the case - that a CPU will run at top-temperature while idling, if it's running at 100% clock speed. However, I've configured it to run at 100% because it runs dog-slow all the time and sits at 31% while compiling. If I can resolve this issue then I'll change the settings back to something more sensible. Thanks. – mackenir Mar 31 '11 at 15:17
Underclocking the cpu allows it to not only draw less power, but also lower the cpu voltage and underclock the ram as well. So reducing clock speed also greatly lowers idle power consumption. It's the reverse effect of what you have to do when you raise the voltage for the cpu when overclocking a desktop. This has a huge impact on battery life. – Joel Coehoorn Mar 31 '11 at 15:35
OK sure, but perhaps wouldn't cause full-bore fan usage. Anyway - going off at a tangent - these settings are to eliminate reasons for the CPU not reaching full speed. – mackenir Mar 31 '11 at 15:47

7 Answers 7

up vote 4 down vote accepted

If you don't want your CPU to throttle down you need to enter the BIOS and disable either Intel "SpeedStep" or AMD "PowerNow!" technologies. These lower your CPU power when its not being used so your computer uses less power, produces less heat etc.

In other words your CPU is slower when you are not using it and speeds up when you need it to.

For a laptop I would recommend leaving it on unless you always have it plugged into the wall and the area it is in has good air circulation.

share|improve this answer
"your CPU is slower when you are not using it and speeds up when you need it to." Sorry I didn't make myself clearer in the question - the laptop runs slowly all the time and never ups its CPU clock speed even when doing CPU intensive stuff, and despite specifically setting the power management settings to run at 100% – mackenir Mar 31 '11 at 15:18
turn off the speedstep/powernow and see if it fixes the issue... not sure how the power management settings work so cannot comment on them. – Arctor Mar 31 '11 at 15:32
I disabled %proprietary variable clock speed feature% in the BIOS and things are running faster now. It is a shame that the feature doesnt seem to be working properly on this laptop but at least the thing is running better. Interesting fact: the temperatures of the CPU etc are no different from before, and the fan is also the same loudness as it was previously. Weird huh? – mackenir Mar 31 '11 at 16:35
Sit it on a pillow and see how well it does with temps at max speed lol – Arctor Mar 31 '11 at 17:33
You may want to try to reset your power scheme to default and not tweak the CPU settings then enable SpeedStep/PowerNow again. It may start working then. I say this because I read on a forum they are completely separate from one another so they may have been conflicting. – Arctor Mar 31 '11 at 17:35

I recommend you to check the temperature of the computer CPU, it could be due to overheat.

I do not know how old is your laptop, but they tend to catch dust really quickly. So if the diagnostic is correct, you may want to clean it a bit to recover full air circulation within the case.

BTW the monitor says you are using 31% of maximum frequency, not that the maximum frequency is 31% of the nominal.

share|improve this answer
Thanks. Yes that's how I took it to mean - the CPU is running at 31% of max frequency. – mackenir Mar 31 '11 at 14:50

It's not "underclocked" as modern speed step and PowerNow can scale the processor as needed extremely quickly, to the point that it does not affect the performance of your programs.

What is more likely is that your computer is underpowered for what it is you are expecting it to do, or there are unnecessary applications running on the system that can or should be removed.

share|improve this answer
I dont think CPU always running at 31% clock speed (ie underclocked - obviously due to speed-step) is a symptom of it not being powerful enough to cope with tasks. A symptom of that would be CPU clock at 100% a lot of the time rather than never. Cheers. – mackenir Mar 31 '11 at 15:48
Many applications do not really tax modern processors. There are other aspects of the computer that may be related to system slowness besides just the processor. A true measure of system performance takes into account the hard drives, memory, and graphics to name a few systems. In a laptop this is especially true as the components are generally selected for power consumption rather than speed. It is possible the 31% indicates a processor problem, but in my experienced opinion I do not believe this is the case. This is only my opinion and I do not have anything else to back it up with. – music2myear Mar 31 '11 at 16:52

You are using a Dell laptop, dell BIOS' are known to limit the CPU frequency if it powered by an adapter that's lower than the system recommended rating.

See here for more details, if you don't want to use a higher rated power adapter, try this tool called RightMark CPU to remove the BIOS limitation and let the CPU run at full speed.

share|improve this answer

O.K., after some 5 hours of research and experiments, I've got a diagnosis for my Lenovo G560 (dual core P6100 CPU @ 2GHz) - my problem was that it stuck at 46% of the original CPU frequency, with several episodes of 25%, which considerably lowered my ability to use CPU intensive software like Photoshop and games.

The problem was/is overheating and is not related to Windows 7 and it's power management. As far as I understand, the computer BIOS downclocks the CPU multiplier to x7 every time the GPU's temperature rises over 82 degrees Celsius and restores the x15 multiplier when the GPU cools down under 80 d.C. It would probably lower the CPU frequency when other parts of the system overheat, like the CPU cores, but I could not test that, because the GPU always has the highest temperature.

What was actually happening was that HDD-intensive tasks (a combination of Tortiose SVN with huge repos, Cloud Antivirus, ZonAlaram with high traffic and Photoshop using scratch disks) were causing the HDD temperature to stay high all the time, which was causing the GPU to overheat, especially when Photoshop was running and causing the CPU cores to get hotter. As a result, the BIOS never let the multiplier get more than x7, except immediately after the boot up of a cold laptop.

The solution was a) opening and cleaning the laptop (which was not particularly dirty, so this had no effect) b) removing the antivirus c) putting the laptop on this notebook stand Canyon CNP-NS4 (google it)

Now it seems to me that the BIOS uses more often the x15 multiplier and I get no more 500MHz speeds.


What I used for tests:

I found the tool while reading the following forum thread: (read it for more info on the tool)

share|improve this answer

Old post, but thought I'd post my findings on a Dell E6530 here:

Using an external AC Powersupply running at 19.5v 3.34A produced roughly the same problems for me. 2.4Ghz CPU running at 600Mhz.

Switching to a 19.5v 90watt (4.62A) PSU clocked my CPU at 3.2Ghz. No other changes were made.

Funny thing is that the 65Watt (3.34A) PSU according to Dell is a valid accessory...

Anyways, just thought I'd post this for anyone having similar problems with CPU's underclocking for no apparent reasons and who's browsing the web, just like I was =)

share|improve this answer

You need a battery in the laptop, even though you're running on mains power. I only have one battery amongst three laptops, the wife got mine, when hers died. Just tested the other two battery-less laptops and no battery means reduced CPU frequency. Even under stress they will never go above the percentage shown in resource monitor.

In my case one laptop was locked at 46% CPU frequency, the other was 53%. With battery in laptop but on mains power you get 100% cpu clock speed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.