Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 3 identical new HP laptops, on which I have installed a fresh (legal) instance of Windows XP SP3 32bit from an original media, and a legal copy of Microsoft Office 2000 SR-1 Premium, also from an original media. For Office 2000 I did a customised installation and only installed Access and Powerpoint. None of them starts on any of the new PCs.

Access crashes at start and the only technical info I can gather are:

AppName: msaccess.exe AppVer: 9.0.0.6620 Modname: unknown ModVer: 0.0.0.0 Offset: 000c030e

Edit: the event viewer reports an Event ID = 1000 and the message:

Application Failure msaccess.exe 9.0.0.6620 in unknown 0.0.0.0 at offset 000c030e.

The application is run as Administrator.

End of Edit.

Powerpoint also dies at the start, and Clippy comes up saying that "An irreversible error has occoured" (translating from italian). But I don't care too much about PP: I need Access though.

Windows is fully updated and the appropriate drivers are installed. vcredist is installed for versions 6.0, 2005 and 2008 of Visual C. I tried without success to uninstall and reinstall again; I also tried to apply the Office 2000 SP3 I downloaded from the Microsoft site. No joy.

Other than these two apps, everything seems to work fine on the PCs.

I've looked for hours and I can't find any helpful tips on these crashes. Anybody has an idea of what I could try to make Access work or at least gather more details about what's wrong?

Thanks.

share|improve this question

2 Answers 2

Have you examined the event logs on the PC? Post any errors there with Event ID.

If I recall, you also need to run the applciation as Administrator one time. Seems I recall it makes some odd registry entries that require elevated permission. Is the user an Administrator?

share|improve this answer
    
My attempts are done using the Administrator user. The Event Viewer reports an Event ID = 1000. I have updated the original post. Thanks. –  MacThePenguin Apr 1 '11 at 6:39
up vote 0 down vote accepted

This is what I did to make it work:

  • Uninistalled everything Office-related (again);
  • Using regedit I tried to delete all of the Office registry keys: I found HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office. When I tried to delete it and its children, one node wouldn't go away (b7eff951-e52f-45cc-9ef7-57124f2177cc). The authorizations seemed right... So I selected a parent node, and in the authorizations I made it so the children nodes would inherit the authorizations from this node. After this I could delete the whole HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office branch;
  • Reboot;
  • Reinstall Office 2000, again a customised installation, with the full Access, the Office tools and all the filters and converters;
  • Launched Access, and now it works as expected.

I'm not entirely sure what I did different from the first time I installed it. Also, I tried this only on one of the three PCs mentioned in the original post. Finger crossed that the others will work as well. :)

Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.