Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 5 computers and 1 D-Link modem that is connected to Bezeq (the infrastructure provider) All the computers and the d_link are connected to the switch. Currently only one computer is connected to the internet. How do I set the d_link as a router so that they are also connected to the internet (the provider is 012).

share|improve this question
What is the model number of the D-Link device. Most D-Link devices are routers. – Chris Thompson Apr 1 '11 at 7:46
2500Uץ OK so how do I set up the router to allow the other comuter to access the internet? – Miri Apr 1 '11 at 7:52

According to the manual the router should already be set up to do this. You just have to make sure that the other computers are set up to talk to the D-Link. If you're not using DHCP then you need to make sure the other computers have the same Default Gateway and DNS settings set up on them as the computer that can access the internet.

share|improve this answer

You need to set up the router as the DHCP-master for the network, and disable this function in the switch. Set all the other computers with auto-DHCP and DNS.

The functions of the switch should not include DHCP or DNS, so that it serves only as a transparent network connector, and it also should accept DHCP (if it cannot, assign it a static address in the range given by the router but high enough in the range so that no conflicts are possible).

In most cases, this should be enough to get all the computers going. If not, verify everything per the answer by Matt Jenkins.

share|improve this answer

You need to turn your D-link to become a modem router and release DHCP to the switch. Since there is only one computer connected to the internet i suspected that your modem is turned into bridge mode. Set it into routing mode and then turn on DHCP of your D-link and then make sure all the 5 computers are in auto dhcp mode.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .