Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a network comprised of two segments:

  • Segment 1: IP adresses xx.yy.178.n - my main segment which is connected to the internet via DSL
  • Segment 2: IP adresses xx.yy.1.n - WLAN segment used for mobile devices, the router for segment 2 is connected to segment 1 so the mobile devices can connect to the internet as well

My problem: I've got a network printer in segment 1 (an HP CP1518), my mac is in segment 2 and can't see the printer. If I hook the mac up to segment 1, everything works fine.

My question: How do I have to set up my routers in order for the mac in segment 2 to "see" the printer? Which tools can I use to figure out if the problem is with the router for segment 1 or segment2? I've played around with opening some ports, but no success so far.

Any tips are appreciated.

share|improve this question
    
I've done some more digging around, and by now I'm sure it can't be a network issue ... I can ping and traceroute the printer, and I can call up its webpage using the printers IP address. Looks to me that I can reach the printer .. but why is my Mac thinking it is offline? –  IronGoofy Apr 2 '11 at 19:43
add comment

2 Answers 2

OS X uses the CUPS system for managing it's printing. The interface you see normally only has a small subset of what CUPS can do.

If you browse to http://localhost:631 you should get the full CUPS interface where you can do wondrous things, including adding printers using many different protocols and by their IP address etc.

The CUPS manuals can be found here.

share|improve this answer
    
Thanks Matt, I tried opening TCP and UDP ports 631 on the main router, but that didn't change anything. Anything else I should try? –  IronGoofy Apr 1 '11 at 12:38
    
IronGoofy, he means type to 127.0.0.1:631 in Safari. No need to open ports or anything. –  emgee Apr 3 '11 at 5:25
add comment

I've solved the issue, but I'm still not sure what has caused it.

The solution was to simply delete and re-create the printer using the IPP protocol and the printer's network name. The Mac could see that, and everything was fine.

I can only assume that the Mac initially used the printers IP address to set up the printer, and that that has probably changed. But that's only a wild guess ...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.