Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a Windows XP laptop and recently inherited a monitor. It unfortunately remains blank when attempting to extend. Things I've tried:

  • Different resolution settings
  • Checking the "Extend my Windows desktop onto this monitor" box
  • Using laptop (HP EliteBook 6930p) function keys (fn + F4)
  • Rebooting

I can't find anything wrong. The monitor should work ok as it was yesterday for the person I inherited it from. When checking the option to extend the laptop desktop, I am able to move my mouse beyond the right border. However, nothing shows on the monitor itself. I've checked to ensure the cable is secure. The monitor's power light is green.

Anything I forgot to check or other ideas? :-/


share|improve this question
up vote 1 down vote accepted

Did you make sure you have the most recent graphics driver? I've used that model of laptop and I know that it works on Windows 7. Since you're using Windows XP, you may need to try the different drivers available. Here's what I'd do:

  • Go to Device Manager and try to upgrade your graphics driver and monitor drivers
  • If that doesn't fix it, go to HP's website and download drivers here
  • Try each one, reboot, and see if it works

If that doesn't work, figure out what kind of graphics card your laptop has and try to find new drivers from the manufacturer. Besides that, it could be a problem with Windows XP compatibility.

share|improve this answer
Those are good ideas. Thanks. I've never had a case yet where I've not been able to at least get something to display. Even the on-board menus wouldn't show. Another guy couldn't get it to display at my desk either so I used another one instead and it worked like a charm. – MattB Apr 8 '11 at 14:48

I am having this same problem with my 6930p, and I had a very similar problem with the Elitebook 8530p, where coming out of standby would stop the external monitor from powering up, amongst other glitches with the soft touch buttons.

Updating the 8530p BIOS fixed all those issues.

I'm waiting patiently for IT to install the updated BIOS on this 6930p, as I don't have admin rights, and they need to do it in person. I'll try to remember to pop back and update this post afterwards to let you know if it fixed it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.