Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I followed the directions here and the colors are correctly showing, however the background is still white, what else do I need to do?

Note: I did a sudo nano ./bash_profile instead of .bashrc

share|improve this question
1  
First of all, do not, do not use sudo unless you absolutely have to. Editing your ~/.bash_profile does not require super user permissions. –  Wuffers Apr 1 '11 at 21:26
add comment

2 Answers 2

up vote 1 down vote accepted

From the terminal click the Shell menu, then click the Show Inspector menu item. Alternatively, you can press Command-I. In the inspector, click the Settings button, then select a dark setting such as "Pro".

If you want to customize each the settings (font face, font size, background color, ...) then press Command-, for the preferences, then click the Settings at the top. You can now customize existing settings, or you can add your own.

share|improve this answer
add comment

You need to change the settings in Terminal itself, rather than in your login or bash startup scripts. I forget exactly where it is, but if you look for Preferences in the menus for Terminal and look for Colors - I think it's in a small window as a dropdown selector - then you can change all the colors, including the default background color.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.