Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several Firefox profiles and I have them pinned to my taskbar.

Since i installed windows 7 SP1 I can no longer have both there. Is there a way to fix this so that I can have multiple instances of the same program pinned at once?

share|improve this question
    
See my answer here. (Possible duplicate) –  hegearon Jul 30 '11 at 9:02
add comment

2 Answers

You either pin an application or a document to an application. I guess you want the first behavior where you have more than one pinned application on the taskbar itself. I thus suggest you to rename each instance of Firefox and leave the default (in which new links should open) named firefox.exe.

So you have:

  • firefox.exe (new links)
  • social.exe (profile optimized for social stuff)
  • multimedia.exe (profile optimized for music/movies/...)
  • work/school/research.exe (profile optimized for more productive things)
  • ...

Then just change the shortcut properties so that each loads a different profile.

share|improve this answer
    
It kind of worked but is buggy and now annoying so it isn't acceptable anymore. (I tried changing the icon like others suggested but i think i did it wrong) Its very buggy, if one instance is open i cant click on the other (so its pointless to having it there) –  acidzombie24 Apr 3 '11 at 21:30
    
I don't know of any other way, multiple instances get grouped up under one thing. Perhaps what you meant can be solved by turning off the combine feature under the task bar properties? So the instances don't get grouped up under the same process. –  Tom Wijsman Apr 3 '11 at 22:29
1  
actually i may have been confused. I meant if one instance was opened then the shortcut would not open. But it does. Maybe i was confused bc one of the two shortcuts disappeared on restart. But that isnt so bad if i leave a shortcut on my desktop and pin it after i restart. kind of annoying but not terrible –  acidzombie24 Apr 4 '11 at 5:01
1  
Another catch is if i open up the 2nd instance, to open the first i need to shift+click it. Which one might think opens the 2nd shortcut BUT IT DOESNT. wtf. I dont know why sp1 remove (or broke?) this feature. It worked perfectly before SP1 –  acidzombie24 Apr 4 '11 at 5:19
    
So this worked before SP1. I guess an option could be to place the RTM version of explorer.exe of the responsibe DLL back, I don't see any other easy options... –  Tom Wijsman Apr 4 '11 at 15:07
add comment

Enable this first : http://windows.microsoft.com/en-US/windows-vista/Show-or-hide-file-name-extensions

  • Create an empty file somewhere and call it "firefox1.exe"
  • Drag & pin it to taskbar
  • Rename the file to "firefox1.bat"
  • Shift+Right-click the taskbar icon & select properties
  • Change the target to ".bat" from ".exe" (since you renamed your file)
  • Edit firefox1.bat & add start <path to firefox app>\firefox1.exe
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.