Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Emacs (23.3.1) with Tramp to edit files on a remote SSH server. Right now these files are being auto-saved / auto-uploaded about once every minute. During each upload, anything I type does not show until after the upload is finished, and it's getting a bit distracting.

Is there any way to change the auto-save / auto-upload frequency for Emacs with Tramp? It can be a Tramp-specific or editor-wide setting — whatever works best.

share|improve this question
up vote 3 down vote accepted

See here: http://www.gnu.org/s/emacs/manual/html_node/emacs/Auto-Save-Control.html#Auto-Save-Control

Basically, you want to set auto-save-interval to the number of characters typed between auto-saves.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .