Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two 1TB drives in a RAID 1 setup using Windows 7 because my motherboard doesn't support SATA III RAID. My questions revolve around the re-sync of the drives. My system seems to re-sync the drives at least weekly and it's a time consuming process that obviously comandeers the drives making anything that requires CPU/GPU/HDD run extremely slow and choppy.

When does Windows determine the need to re-sync? Is there a way to schedule the re-sync to avoid heavy work times? Why does it re-sync? It would seem that mirroring should write to both simultaneously.

Suggestions for a better solution than Windows mirroring?

share|improve this question

migrated from serverfault.com Apr 2 '11 at 2:27

This question came from our site for professional system and network administrators.

3 Answers 3

There are any number of events that might trigger a resync, but you really shouldn't be seeing it on a weekly basis. Have you been shutting your computer off properly? Unclean shutdowns always trigger a resync with windows software raid. Other than some kind of problem with one or both of the drives, this is the only thing I can think of that would cause a resync on such a regular basis.

You can also check the event log (Event viewer > windows logs > system) for possible causes of the resync. Look for events with "Disk" as the source.

share|improve this answer
    
I shutdown the computer everynight, except when running a backup. I use the Windows Shutdown to turn it off. The drives are new within the last three months. I went throught the log and the only Disk events this month were related to my DVD drive from when I was trying to install Ubuntu in a VM. I did find some NTFS errors that pointed to corrupt file system, but now with the re-synch complete, the chkdsk found nothing. I'll have to watch that. –  user74624 Apr 2 '11 at 14:05

If your SATA drives are set up in the BIOS in IDE emulation mode, change to AHCI.

  1. You must make a registry change (Google for it) before the BIOS change.

  2. Don't keep the Windows AHCI drivers, after you've set up AHCI load your motherboard's latest AHCI drivers. I had clicking with default Windows drivers, but the drives work fine with proper ones.

share|improve this answer

Check the routing of your Sata cables, typically internal Sata cables are Not shielded, routing too close to other electronic devices in the case can cause problems.

You can also try replacing the Sata cables with higher quality ones.

They make shielded internal Sata cables, they are harder to find (usually found online only) and are stiffer than normal cables.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.